No response from AT+WDWL


#1

Hi all,

I’m trying to upgrade the firmware of a Q24PL001 using Hyperterminal. All AT commands appear to work correctly except AT+WDWL:

at+cgmr
657_09gg.Q24PL001 1954500 102706 18:44

OK
at+wopen=2
+WOPEN: 2,"AT  v03.12"

OK
at+wdwl?
+WDWL: V02.1B

OK
at+wdwl
+WDWL: 0

But no symbols to trigger the XModem download start and the device will not respond to any more AT commands.

What am I doing wrong?

I’ve also tried DWLWin (4.1.6.1.3) which got to the end of ‘Installing Downloader into Wireless CPU’s memory…’ and then timed out (via grounding the BOOT pin via a 1k resistor).

Best regards,
Richard.


#2

Hi,

I am facing exactly the same problem while trying to upgrade the module.

Have you been able to resolve the issue or find any other way to upgrade the firmware?

Thanks,
~Ales


#3

Just check whther the voltage levels provided are correct… In case everything is correct and this is still not working , then you immediately need to contact your distributor regarding this …


#4

Thanks for reply.

I checked the voltage levels and they are all in expected range.
The main supply VCC is set and checked at 4.00V.

Additional information is that the GSM LED turns on after 1 second after
power on and afterwards it stays on.

Initially, I have played with AT commands on the problematic unit to enable data link,
after this I have problems with “NO CARRIER”, eventough I get correct response
about SIM card and signal quality. Additionally, the unit successfully finds 3 networks,
but I does not want to register on the home network.

We have built 5 identical prototypes and all other 4 are working as expected,
as far as calling or SMS-es are concerned. I would like to understand what has
happend to the problematic module in order not to “brick” the other 4…

Regards,
~Aleš


#5

what are the responses to AT+CSQ, AT+CREG? and AT+CPIN? command…?? is the same SIM working in other modules…? do all of them have the same firmware’s…??


#6

paruthiv, here are the answers to your questions:

13:17:03.090> at+csq
13:17:03.090> 
13:17:03.152> +CSQ: 31,0
13:17:03.152> 
13:17:03.152> OK
13:17:07.909> at+creg?
13:17:07.909> 
13:17:07.909> +CREG: 2,0
13:17:07.909> 
13:17:07.909> OK
13:17:16.109> at+cpin?
13:17:16.109> 
13:17:16.109> +CPIN: READY

The same SIM is working in other modules and in my phone.
All the modules have firmware vesion 6.57E installed.


#7

Additionally,

here are the results of find the networks,
but unable to register. (izimobil is home network)

13:24:10.473> at+cops=?
13:24:44.837> 
13:24:44.837> +COPS: (0,"izimobil","izimobil","29341"),(0,"SI vodafone","SI voda","29340"),(0,"SI VEGA 070","VEGA 070","29370")
13:24:44.837> 
13:24:44.837> OK
13:24:57.668> at+cops=1,2,29341
13:24:57.668> 
13:24:57.668> OK
13:25:03.302> at+cops=?
13:25:22.893> 
13:25:22.893> +COPS: (0,"izimobil","izimobil","29341"),(0,"SI vodafone","SI voda","29340"),(0,"SI VEGA 070","VEGA 070","29370")
13:25:22.893> 
13:25:22.893> OK

#8

This is strange… Do u remember exactly what you did in this particular module which made this work like this… I feel firmware change would solve the problem but since you are unable to do, i think the best possible thing would be to contact your distributor regarding this…


#9

No, unfortunately I can’t remember the specific commands to the module.
But this commands were all in the manual, the chapter about establishing data link.

I have contacted the distributors as you suggested, I hope I will get any answers.

Thank you for your help so far!