No response beyond echo on WMO2


#1

Hi. Hope this is the right forum. My sincere apologies if not.

I just bought an older WMO2 to do some SMS development testing. I built my own serial cable (pinout at end of post).

I inserted a T-Mobile prepaid SIM card, and connected the power. The unit starts up with a solid LED which then switches to slow flashing (about 1Hz).

When I connect my terminal application with the recommended settings (8-N-1, 115,200 bps, hardware flow control), I get an echo back from the unit but no response. In other words, if I type ‘at’ I see the characters ‘at’ in my terminal. However, I do not get ‘OK’ or any other response from the modem, and everything appears on the same line (no carriage returns). Local echo is turned off. I would think that if my cable were not working properly I would get garbage, or nothing.

Anyone have any suggestions? Alternatively, a source for a prebuilt cable would be helpful as well.

Thanks!

/adam


#2

Hi adam@usa.net
Here is the pinout of the fastrack
I dont have the specs for the WMO2 anymore but it should be the same


#3

Thanks. Redoing the wiring worked, after I dialed the baud rate back to 9600 bps. I think what was happening before was that I had somehow wired it to loop back, and thought I was hearing from the modem. Dumb. :smiley:

/afb