EM7565 in USB adapter /dev/ttyUSB2 does not echo

I’ve been working with an EM7565 module plugged into a USB adapter which is then plugged into a Linux host. On two different machines I can install the adapter (with EM7565) and the LTE device comes up and works as expected; however on one of the machines I am not able to see any character echo when issuing AT commands through /dev/ttyUSB2.
In both cases I disable ModemManager and use a serial port interface tool to directly connect to the port (/dev/ttyUSB2), but only on one of the machines am I able to see what I type (as well as the response). Any idea why that would be the case? I’m aware of the ATE command, that isn’t the problem.

Is that really AT command port?
Have you tried other port like /dev/ttyUSBx?

Btw, are you able to test in windows?

I’m about 99% sure that is the correct port. There are only three tty ports under /dev: /dev/ttyUSB[012]. Plus, the initialization scripts that successfully start up the link actually assume /dev/ttyUSB2, so it must be correct because the link does come up successfully.
This is on ModalAI’s VOXL1 platform by the way.

I have not done any testing on Windows as of yet.

then can you see the actual AT command communication on the initialization scripts?

I can see that the script writes to that port, but it uses “echo” so there’s no verification that it actually worked (except for the fact that the link does come up properly).

what AT command did you send in the script to make the link coming up?
Are yo using PPP dial up or AT!SCACT command to establish data connection?
How do you set APN in your script?

The configuration script does this:
echo “AT+CGDCONT=1,\“IP\”,\“phone\”,\“\”,0,0,0,0” > /dev/USB2

How did this script setup data channel?

Unfortunately I’m digging into this without a lot of knowledge on ModemManager and NetworkManager, so I’m not sure I can answer that properly.
Referring to the startup scripts…
The startup script waits for /dev/ttyUSB2, /dev/USB0 and /dev/cdc-wdm0.
Then it waits for system registration looping on “uqmi -P -d /dev/cdc-wdm0 --get-serving-system”.
Then it starts the network with “uqmi -d /dev/cdc-wdm0 -k wds --start-network” followed by “uqmi -d /dev/cdc-wdm0 -k wds --get-data-status”.

Then “echo Y > /sys/class/net/wwan0/qmi/raw_ip” and then a dhcp request… “udhcpc -q -f -i wwan0”

What AT command has been sent?
Not quite sure if your scripy is really sending AT command successfully

The only AT command issued in the script is at config time with the “AT+CGDCONT=1,…” I mentioned above; however, that command wouldn’t have changed anything because I did the same setup (with the same modem) on my Ubuntu machine (where I know the AT commands work because I see responses) prior. So its possible it was never working.

On VOXL, I am not able to verify that the AT command is actually succeeding because I don’t get any feedback; so it’s likely that they have not been working from the beginning. To verify this, I just issued that AT command with a different APN on VOXL, then removed the modem and put it back in my Ubuntu machine and ran AT+CGDCONT? and sure enough it didn’t change.

Note that if I use the RC7611 on VOXL it works fine. Does this make any sense?

Are you using the latest mbpl usb driver?
What is the kernel version ?

/ # uname -r

Regarding mbpl… I know I updated my Ubuntu host, but I can’t say for sure at the moment what is running on VOXL.

It seems to be old kernel…

I remember mbpl driver supports since kernel 4.4…

You might need to install old gobi serial driver


Even though it seems to work just fine with the RC7611?

You said that ubuntu works fine with em7565

Right… both work on Ubuntu, but only RC7611 works (for me) on VOXL.

then maybe this is VOXL driver issue

Yep, it certainly could be (I’m talking to them about this as well). Just trying to cover all the bases…
Are you aware of any reason why this interface would be different between the RC7611 and the EM7565.
BTW… thanks very much for the responses…

As you are not using the official driver (i.e. MBPL USB driver), I have no idea on why it works on RC76 but not in EM7565.

As mentioned above, your kernel is old, you can install the old Gobi serial driver and see if it works.