EM7565 Serial Ports AT Interface


got my EM7565 today. I want to change the Modus to MBIM for my router.
So i installed the drivers for WIN10, and i connect to the COM port and want to set up.

So now i have the Problem:
Windows shows me:
COM3 => NMEA Port
COM4 => WWAN Modem
COM5 => DM Port

So i can connect to all ports with PuTTy. But i can not send any AT commands to any interface.
I tried so change the Speed for COM Ports, and set this in PuTTy, but i dont have any success.

On my Router (turris omnia) i have the same Problem. I got ttyUSB0, ttyUSB1 and ttyUSB2 - i can connect to this, but i can not send any AT command.

what is the problem?
any ideas?


I believe that module was working fine where on windows environment, putty should be working fine. You can install HyperTERM instead and could you check below syntaxes.


You can change MBIM or QMI by changed ATi!USBCOMP=1,1,100D or AT!USBCOMP=1,1,50D followed by AT!RESET

Under Linux serial port is represented by ttyUSB2 ( i believe) where you can use minicom as example.


thanks for you answer.

The problem is, i cannot write any letter in the terminal (windows and linux). I have a black screen, and i can not do anything. So i can not change the Mode to MBIM


I see, you can try install Sierra QMI drivers manually by supply “USBCOMP=8”. I’ve looks like the same problem when I’ve installed latest Sierra QMI drivers on my EM7455 where ports were shown inside windows Device Manager and resolved by supply “USBCOMP=8” (believe for MBIM). I believe shall be applied for your module as well.

A parallel port is a type of interface found on computers (personal and otherwise) for connecting peripherals. The name refers to the way the data is sent; parallel ports send multiple bits of data at once, in parallel communication, as opposed to serial interfaces that send bits one at a time.

ok now it is working. I have not do anything… only tried to connect again in, and it works now!

thanks gyus!

got another problem, but i will open another thread