EM7455 Unable to run AT commands via com port

I have a mc7455 in a PCI express to mini pci adapter, plugged in via USB header. I got the device connected and flashed to the verizon firmware, and it will connect to the network and work successfully… for about 10 seconds, and then it resets. I am on latest firmware, and I’m guessing it is the qmi mode on windows not being reliable and needs switched to mbim. I see 3 com devices in device manager: Communications Port(com1), Sierra Wireless… LTE-A DM Port(com11), and LTE-A NMEA Port(com10). I have seen all the AT commands to switch this to single device more(or something like that), but the problem is I can’t get it to respond to any commands. I have connected to com1, com10, and com11. Com10 in this case is GPS and I see output flowing on occasion, but none of the connections ever take any input. I have tried ati to output status, I have tried to run ate1 to enable echo, but I never get any indication that my keystrokes and commands are being sent. Has serial been disabled potentially? Is there a way to reset it/reenable it?

Hi dancash04,

You can get AT port number from Device manager -> Modems - >Sierra Wireless Snapdragon™ X7 LTE-A WWAN Modem -> Modem tab



I guess Windows might have potentially disabled it (its only a bit mask free for anyone or thing to change), do you have the option of plugging the unit into a Linux system? Its just that its easier to see what is being enumerated at a Linux command line. Alternatively a screen shot of the device manager with the ‘modems’ and ‘Ports’ sections expanded will give a god idea about what is enumerated on Windows.