COM Port for AT test commands at EM7455, Windows 10

Hello everybody,

I’m currently trying to get a EM7455 M.2 card working under Windows 10 Pro, so I can run the factory test mode available from the AT-commands.

Unfortunatelly I do not have any COM-ports assigned with the EM7455, so I cannot enter any commands. I already tried installation of the driver build 4743 or 4581, Skylight 4260 or 4442 and updated the firmware to the newest version. But still I do not have any COM-ports with whom I could connect to the EM7455.

I already run a test with the AT test commands on a MC7304 and had absolutelly no trouble there to get it working. So I’m wondering if the missing COM-ports are intended or if I’m facing a bug or other problem?

Best regards,


I’ve EM/MC7455 installed on DELL E7270 and E7240 running dual boot (Windows 10 and Ubuntu 17.04) without any issues. For EM7455 (M.2 model)
installed internally on DELL E7270. I’ve another MC7304 installed on LENOVO X220/X220T running Windows 10 also without any issues. Which hardware model have you used to install that module ? Because certain hardware model is not fully compatible with EM/MC7455 if installed internally.

I also do not have any functional issues. The card is recognized by the system and I can connect to the mobile network. I’m also not using any Laptop but a industrial PC with M.2 Slot.

I need to use the AT commands for stress tests of the card with the system. For that, I usually connect to the cards’ AT-COM Port. I already did this on several LTE-modems which showed the required AT command port in the device manager right after driver installation. But the EM7455 does not show the AT command port in the device manager, “only” the modem and network device.

Now I’m wondering whether or not the EM7455 can receive AT commands via a COM port and if so, how I can activate it…

Reinstall the Sierra Wireless Windows driver package with ‘USBCOMP=8’ as a command line parameter This will select a default USB composition with the DM NMEA AT and MBIM functions enabled.


I’ve EM7455 installed internally on DELL E7270 running Windows 10. I haven’t change any USBCOMP parameters (factory default) besides installed latest Sierra QMI drivers. I’ve installed “HYPERTERM” to access EM7455 where example as below:

Manufacturer: Sierra Wireless, Incorporated
Model: EM7455
Revision: SWI9X30C_02.24.05.06 r7040 CARMD-EV-FRMWR2 2017/05/19 06:23:09
FSN: LF618304770110

Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 0000100D (diag,nmea,modem,mbim)


Thank you, that worked for me. Now the device manager shows two additional COM Ports and I can access the third and hidden one in TeraTerm