New dev kit for EM7430 can't get anything over usb


#1

I just received new development kit and EM7430. I 'm using WIndows 7. I found USB driver package and dev board is showing up as 2 COM ports:
Sierra Wireless Snapdragon X7 LTE-A DM Port (COM7)
Sierra Wireless Snapdragon X7 LTE-A NMEA Port (COM8)

I’m opening a terminal emulator to send AT commands. There’s no prompt, I can’t get any response from a simple ATI commands.

I tried 2 different PCs (Win 32 and Win 64). I tried Tera Term and Putty terminal emulators. - Nothing is working.

  1. Are there more drivers or SW I need to load?
  2. Is there Baud rate information?
  3. Is there any good documentation on using the dev board with the module? The 1 page Quick Start Guide is very limited.
  4. I see something about connection manager SW. Is this necessary if I just want to send the AT commands?
    Thanks,
    awhenley

#2

Hello,

Besides these 2 COM Ports, you should see any device inside (Modem) and (Network Adapters). By right you can access this module via DM Port using any tools such as HyperTERM or Putty. Have you tried send commands atiz and atz ?


#3

Thanks for trying to help. I do see the device showing up in Modems as WWAN Modem and I see it show up twice in Network adapters. I have tried PuTTY and TeraTerm to connect to the DM Port. I have tried all kinds of AT commands as well as +++, but there is simply no response from the Modem. I don’t know if this is a clue, but I installed Skylight Connectivity Manager. It detects the modem but says Mobile Broadband is off and “Laptop Wireless switch is off”.
My laptop obviously doesn’t have WWAN switch since I"m connected through a USB cable.

I have tried all this on 2 different PCs with exact same results.

Possibly another clue: I have a Serial Port Monitor program that can monitor message to the device. No matter what I enter, it seems to send every character as a hex “00”. That seems like a driver issue, so I tried 2 different versions of the USB drivers with same results. I’m running out of ideas on this.

Thanks,

image

image


#4

One more clue. I used Skylight to see if I can view module IMEI. It can’t seem to read it. It’s possible module is bad. It’s new and i have another coming tomorrow. If I spent 2 days fighting a bad module…!

The module is definitely powered up. Is there anything else I need to do to enable it. I’m using Sierra Wireless development kit. Thx.


#5

I may have solved with help of Sierra Wireless FAE Jon!

DO NOT use the DM port. This appears to be for monitoring only.

Solution:
Enumerated under “Modems” is the port you need to connect to for AT commands. Open it with Windows Device manager and you’ll see the COM port number. For me, DM port was 88, NMEA was 86, and this “AT” port was 87. Use 115200-8-N-1 and presto - I’m able to send AT commands.


#6

Hello

I’ve EM7455 module installed on DELL E7270 running win 10 64 bit and installed with Skylight Build 4260 instead. Yes I got problem with latest skylight release. Please do install Skylight Build 4260 and do check again.

Regards

Zainul


#7

Hello Again,

Just want to add an image (see below)
image

Yes, I’ve an experience with latest Skylight where seem wireless is off as well as mobile broadband. That problem was solved by re-installed with Skylight Build 4260. We could try taping pin #20 (not advice).