Modem does not respond anymore to AT Commands


#1

Hello,

I have got a Wavecom FastTrack M1306B and I wanted to tried the “Hello World” Open AT example. I followed the tutorial suplied with the Open AT SDK (I used the following AT Commands : AT+WDWL for downloading the program file, then AT+CFUN=1 for reseting, and finaly AT+WOPEN=1 to execute the program).

After executing the program the modem stopped to respond to any AT Commands and is not usable anymore. It keeps displaying +WIND: 3 at a regular period in hyperterminal.

I tried various reset AT Commands (AT+CFUN=1, AT&F) but they did not help : modem is answering OK to all the commands without interpreting them.

Have you got any ideas on what is going on ? And how does hardware reset work ? I’ve seen a method with putting a low signal on PIN 14 of DB15 connector, but how can I achieve that ?

Any help would be really appreciated !


#2

Hi,
I got exactly the same result while trying the same thing…
Modem is only sending regular OK’s… and it seems there is no possibility to take the control back on it.
So, we will be 2 happy developers if somebody could help us.
Thanks,
Alain


#3

After some investigations it seems my problem comes from an incompatibility between Open AT 3.03 and the firmware version of my modem.

The modem was sent to my distributor in order to be firmware upgraded.

Achenavier : you can tried to send AT+WOPEN=0 just after modem boot (and then AT+WOPEN=3 and AT+WOPEN=4). It has not worked for me but I was told some people successfully regain control over the modem like that. If that does not work for you, I fear the only solution is to flash the modem firmware (contact your distributor for that).