OpenAT I need help!! M1306B dont accept AT cmds


#1

Hi,
the baud rate of the modem is 9600 like the configuration of hyporterm
i had no problem at this.

I uploaded a hello world open at application, that aparently was nothing hard.
adl_atSendResponse ( ADL_AT_UNS, “\r\nHello World from Open-AT\r\n” );
i used the gcc compiler, and without any link

I used hyperterm and
AT+WDWL
i uploaded the gcc_Hello_World.wpb.dwl that was in the out folder of my Open At first Project.
then when was completed and automatically closed the window
i did the reset, everything worked perfect at this point.
§§§§§§§§§§§§§§§§§§§§AT+CFUN=1
OK
then I…
AT+WOPEN=2 to run the app
and then in theory should say Hello World from Open-AT every 10 seconds,
insted keeps saying
OK
OK
OK
every 10 secs.
I readed a lot what went wrong, and aparently the TRACE function every 10 secs is working, but cant show it in hyperterm because of the IPR i setted to 9600 and it has to be done at 115200 aparently to work like in theory.
The main problem now is, that i cant now Use AT commands anymore
just dont do nothing, I tryed
AT
AT+WOPEN=0
AT+WOPEN=3
AT+WOPEN=4
+++
AT+CFUN=1
Control+C
Control+V
Esc
Control+X
kill
die
end

also i tryed to unplugg it, disconnect it,
and just keep saying OK every 10 secs,
I readed here another posts with other kinds of modems that have the same problem and, a short with 1K resistor between pin3 and pin9 should hard reset the modem, but, where?
in the DB15 modems connector, or
in the DB9 Serial pc connected-to connector?

exist another way to hard reset the modem?

Thanks in Advance
Daniel.


#2

Please can somebody confirm if the short pins are correct for hard reset the device?
Thanks,Daniel


#3

Using the reset pin is no different to power-cycling the device.


#4

What can I do? to turn off the uploaded program

can you tell me if my procedure is ok?
i mean for the gcc_Hello_World.wpb.dwl is that the one i should upload?

Thanks and sorry for my ignorance…


#5

Usually you should use AT+WOPEN=1 to start an embedded application. Maybe that helps…


#6

I put that and it says OK
but not like an answer, its more like the 10 seconds OK
for ex:
AT+WOPEN=1
OK
OK (10 secs later)

OK (10 secs later)

OK (10 secs later)
OK (10 secs later)
OK (10 secs later)

seems that is not responding to any AT command
is there a magic way to turn off Open at application?

Thanks in Advanace.
Daniel


#7

It’s not magic - it’s documented in the AT Commands guide:

AT+WOPEN=0 - Stop the Open-AT Application;
AT+WOPEN=1 - Start the Open-AT Application.


#8

I know but in my case I do need some magic or something, because those commands doesnt work also any AT Command dont work, because of the OpenAt project running application

Any ideas i would be glad
Thanks


#9

Use DWL Win