MC7750 Update failed twice, then Flashtool says modem not detected

I tried to flash an MC7750 with FlashTool_MC7750_03.05.10.13_00_vzw_033.012_000.exe, the flashtool reported that the download failed with a timeout at, I want to say at approximately 15 percent, tried again and it failed at 22 percent and now it is unable to detect modem. It now shows up in device manager as an “Other Device” and it’s Comm Ports are not listed. Tried rebooting, still unable to detect the modem. Is there any way to fix this modem?

Here is more information on this device:
I originally tried using another MC7750 that was originally working in a HP laptop and I tried to move that modem to a Lenovo T430 Laptop but it wouldn’t work. I thought it may be the fact that that modem was meant for HP only so I ordered a new modem. When the new one came, it was in a sealed Lenovo box and after registering the new modem’s IEMI with Verizon, it appeared to register and it even showed the phone number for the account but Windows would not establish a connection and said that it could not find an APN. I tried replacing the original SIM with the new one that came with the new modem that came with the new modem and registered the new SIM with Verizon but My Windows Laptop still said it needed an APN. Checked with Verizon tech support who attempted to re-provision the SIM but they indicated that they never saw the SIM, they told me to go to a corporate store and have them try replacing the SIM with another new one, which I did but they tried getting it to work but never could get it to work.

After that, I went home and tried to flash the modem, which failed and now the modem only appears in Device Manager under “Other Devices”. Can anyone tell me if this device is recoverable and how to recover it or is it bricked?

Hi ceo5,

Honestly, I haven’t faced this issue yet. Could you please try to update FW by SDK with Ubuntu PC?

Download document at,-d-,26/#sthash.B00YnDId.HVtLyVCZ.dpbs

Download driver at and follow page 11 in order to install driver

Download SDK software at,-d-,00,-d-,23/#sthash.Z2cMTEEu.81ikWAr0.dpbs and follow page 28 to update FW.


1 Like

I do not have Ubuntu or experience with using it. I do have some experience with Linux but was limited to installing SUSE Linux and use on a Linux SIP-based phone system when I worked in that field.

Ok, I was able to install Ubuntu and then was able to build and install the drivers but I am stuck at where to extract or place the upgrade firmware to and how to perform the upgrade. Can you or anyone else help me with this? As I said before, I have very limited knowledge of Linux which was only with SUSE Linux on a proprietary use for a SIP based phone system.
Also, will I be able to install the 1584083_999999_MC7750_03.05.10.13_00_vzw_033.012_000_SPKG.cwe or 1584083_999999_MC7750_03.05.10.13_00_vzw_033.012_000_SPKGZ.cwe
version of the firmware using this method?
Another thing that should be noted that while working on other things not related to this firmware upgrade, I did find that when I booted up to the hard drive partitioning utility Parted Magic that it was able to see, access and even connect to the Verizon network but when I boot back into Windows, the modem is still totally unavailable. I even tried a new fresh install of Windows that it too could not access the modem. I do not know the procedure to connect the modem in Ubuntu.