MC7455 doesn't work correct on Windows (fixed)


I have a really annoying problem…

I run Windows 10 on a Lenovo X301 with removed bios white list. The MC7455 has taped pins 23 till 33 (and I tried to tape pin 20). For Germany this should be the right LTE version.

As USB driver I use

And as “dialer”

At the device manager I see the devices named
Sierre Wireless Snapdragon[size=50]TM[/size] LTE-A DM Port (COM6)
Sierre Wireless Snapdragon[size=50]TM[/size] LTE-A NMEA Port (COM7)
Sierre Wireless Snapdragon[size=50]TM[/size] LTE-A WWAN Modem
Sierre Wireless Snapdragon[size=50]TM[/size] LTE-A WWAN Network Adapter #3
Sierre Wireless Snapdragon[size=50]TM[/size] LTE-A WWAN Network Adapter #4

I can upgrade the firmware, no problem.

The com ports are functional, I talked with the MC7455 with a terminal program.

But then… Windows 10 recognize (with or without installed Skylight) the MC7455 as WWAN module and if there is no SIM card it says “No SIM card”. With SIM card it says “No signal”. But no question about the needed pin code.

Skylight says on Windows 10 every time “No SIM card”.

If I use Windows 7 I see the devices too, but after a really long time Skylight can’t find the card.

Has anybody a idea what I can do to get this combination work?



Hello Stefan,

i have the same Problem. My SIM Card can’t be recognized neither by Windows 10 nor by Skylight. Did you find a solution?

with best regards

Hallo mahrari,

on which notebook?

I have a conversation with sierra and they say it’s a problem of the x301. I don’t believe this because we talk about an USB connection and a Windows 10 integration.



FWIW, I successfully used a MC7455 in a Thinkpad x301 without any problems, except for the need to mask the USB3/PCI express pins. The hardware is definitely compatible. I never ran Windows on it though.

1 Like

I fixed it now.

First… MC7455 can´t work on Windows at default configuration! EM7455 can…

There are two (!) differences between both cards at factory default:

  • connector
  • USB composition

The second one is the problem… MC7455 use USB composition 6 (DM, NMEA, AT and QMI) and EM7455 USB composition 8 (DM, NMEA, AT and MBIM).
I think Sierra forgot to change the USB composition at there windows device driver :frowning: And Linux can handle all modes.
To fix this you need only change the USB composition to 8!

Here is a detailed explanation about the needed steps (Method 1 works really good): … com-ports/

I found one difference between the the device he used and my system. He used the device “/dev/cdc-wdm0” and on my system there are “/dev/cdc-wdm1” and “/dev/cdc-wdm2”.
It’s enough if you use “/dev/cdc-wdm1” like described at the comments:
./ –device=/dev/cdc-wdm1

After changing USB composition to 8 you can use the MC7455 on Windows 10 without further device driver. If you want to use the additional ports install the sierra device driver.



Thank you Stefan, it worked!!! :slight_smile:

Hi guys,
I recently bought sierra wireless MC7455 but our system is not recognizing this device. MC7345 module used to work well. I am using PCIe slot to connect MC7455 but device manager shows no sierra wireless card as detected. Is it a compatibility issue?

Have a good day. Could you identify which hardware, OS and OS releases. Without these all we could not give a concrete advices. For your information, I’ve EM/MC7455 installed on DELL 7240, LENOVO X220/X220T running Windows 10 PRO 64 bit and Ubuntu 17.04 and looks runnung fine with respective related drivers.

A PCIe slot has no USB signals, so that won’t work with any modem.