Insert SIM with EM7455

My EM7455 is using SW9X30C_02.30.01.01 firmware. Can it use VietNam 4G mobile network?
My laptop always show insert SIM. Please help me fix it


Please do check that specific VietNam4G Band through below website.

Thank you for your reply
Please guide me what I should do


I’m from Malaysia and have a same model EM7455 installed on DELL E7270 running windows 10 and ubuntu. Installed with specific sierra drivers and skylight tools (windows) without an issues. Have you compared that specific 4G bands for vietnam ? Believe that sim doesn’t recognized by that module. Have you tried with other sim ?


Thank you very much Zabo
I tried 03 different SIM and different mobile network, but it is still the same
I am using Thinkpad X1 Carbon 4th Gen with Windows 10 64bit.
What mean of “specific sierra drivers and skylight tools (windows)” ?


Have you installed that specific drivers from sierra website ? About skylight actually sierra tools for sierra mc/em series on windows environment but not necessary … because taken care by windows 10 itself


Hi Zabo

I did the both
First : I use windows driver.
Second : I download driver from Lenovo website.
Third : I download from Sierra website
But at the first time its firmware is Rogers(SWI9X30C_02.24.05.06) after that I change it to Generic(SWI9X30C_02.30.01.01)



I see you’ve installed lenovo’s em7455 models but my one is generic em7455. I believe you’ve relabel that module to generic em7455, did you ? Believe already mismatch and other qualified members could help you.

Do not attempt to change the PID of a Lenovo modem in a Thinkpad! The Thinkpad will refuse to boot if you do that.

As for SIM issues: The most common cause is the simplest one - the SIM is incorrectly inserted . Upside down, backwards or not fully inserted in the slot. The Thinkpad X1 Carbon 4th gen should have the SIM inserted with contacts facing up. The side with the cut-off corner goes in first of course - but I guess that is the only logical way…


Thank you for your help
My Thinkpad is working well now without “INSERT SIM” error.
I think I inserted SIM right. Maybe my EM7455 is not compatible with my country mobile network.
But I will try to find SIM contacts facing up for testing
Thank you

Best Regards

Thank you Zabo

I think we need some help from support team
Thank you very much for your help

Best Regards

Any word on this issue? We’re experiencing something similar, all of our X1 carbons have a message that says Insert SIM. There is a sim card installed, it is running the latest drivers and firmware. the SIM card works in Dell devices just not on X1 carbon.
This is the case with AT&T, T-Mobile and Verizon non of the SIM Cards are detected.

Windows 10 1709/1803
Sierra Wireless EM7455

Oh, really

Up to now I can not use it on X1 carbon

I used the latest firmware, inserted sim but It always notice insert SIM

Please drop me information if you can fix it

Thank you

I am still looking into this issue, I have not found any information that is helpful, I know this works on Windows 10 but it seems to be either specific to EM7455 or Lenovo X1. Lenovo suggested the firmware but that did not fix it.

Greeting, it’s piece crap production i have a thinkpad t470s and it came with this Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A crap 4g only 1 sim worked and i can’t change to another sim card it keeps asking insert sim card.

Do you check the followings?