M3DA Error when trying AAF to Airvantage tutorial

I am working on building app for the GX450 through ALEOS. I am currently running through the following tutorial:
I can see the device on my AirVantage, I have added the app and can see it running through ALEOS on the Remote Systems Explorer but the data model will not show up in AirVantage.

In the system log I am getting the following error:

Jan 25 18:34:15 notice ALEOS_APPS_AAF-AGENT: <M3DA-SESSION> Sending data through authenticated and encrypted session
Jan 25 18:34:15 err ALEOS_APPS_AAF-AGENT: <M3DA-SESSION> Failed with status NOREPORT: "/usr/readyagent/lua/m3da/session/security.lua:54: closed"
Jan 25 18:34:15 err ALEOS_APPS_AAF-AGENT: <DATAMGR> Failed to send data for table nmp.uplink:StatePath&CountPath&StringPath&FloatingPointPath&timestamp. Keep data for the next connection. err=Failed with code 500
Jan 25 18:34:15 err ALEOS_APPS_AAF-AGENT: <SRVCON> Error while sending data to server: Failed with code 500

The only setting from the tutorial that I can see for M3DA is the password which needs to be set on the device and on AirVantage and I have done that.

Any ideas why the M3DA data is failing to send to airvantage while I am seeing the device connected and all other data (LWM2M).


Hi Ian,

Your system is not associate to any application (using your application model whih define how your application must communicate to AirVantage. So AV closes the communication for security reason.

You have to associate your application with your system:

  • Edit your systems (from the activity Monitor > Systems > in the system details screen, click on Edit in the More menu)
  • In the application section, click on the glass to search your application from your own repository (not Public repository)
  • Click on the application and validate and come back to the system details dashboard.

In the dashboard, the System Applications widget will list the application(s) declared and which can communicate with AirVantage.

Try again a communication.



Thank you very much for your response. I tried starting everything from scratch and unfortunately I am still having issues.

I have installed the App on my device using Export > Local Application Package in ALEOS. I attempted to install the app via AirVantage but the System Operation of “Install Application” sat on “Pending” for over 30 minutes will no success of installation. I verified through ALEOS that the application is in the App Container after the local package was installed.

On AirVantage I went to Monitor > Systems > Selected my unit > More > Edit and added to application to the application list.

I have my application selected and then clicked save, Is there another step to validate or is clicking save enough?

Now when I view the dashboard for that device I can see the application listed under the “System Applications” widget, but when I click on it there is still no data.

I assume that since the app is in the application widget it should be able to communicate but I am still getting the same error listed above.

If you need any more information or screen shots to help please let me know,


Hi Ian,

As far as I can see, your system is correctly configured in AirVantage: synchronization succeed without any error. LWM2M communication can be seen in the timeline.

I can not see any M3DA communication: that means your application doesn’t communicate with AirVantage either the application is not installed in the gateway (the association is a simple link in the AirVantage database) or the application is not started or the application has a bug.

To install, start it using AirVantage, your gateway must communicate to AirVantage. Communications pace are configured using ‘Configure communication’ button in the top toolbar (second button with an icon). You gateway communicates once a day so you have to wait 1 day before any operation scheduled in AirVantage is consumed and executed by your gateway.
You may decrease it until 1 each 15 minutes (be aware, bandwidth consumption will be increased).

Let’s see if there is any issue in your application once your application will be installed and started. Application log will be useful at this step.



Thank you again for your response!

I was able to change the communication interval to 15 minutes (bandwidth usage is not an issue). I changed the setting in AirVantage, power cycled the device and when it came back online I noticed the System Operation of “Configure Communication” was now labelled with “1 success”. This is the first time I have seem any system operation actually succeed.

I then tried to remove the application (so I could try and install it again through AirVantage as you suggested) and even though It has gone through a handful of communication cycles the System Operation of “Uninstall Application” remains on “In Progress”. I have not been able to successfully install or uninstall an application through AirVantage yet. The System Operation task remains on “1 pending”.

The only way I have been able to get the application onto the device is to install it locally using Developer Studios for ALEOS. I then assign to app to the device through AirVantage as we have previously discussed by going to Monitor > Device > More > Edit and adding it into the Applications window. Perhaps I am having issues with communications because I am not able to install the application over the air? I assume there is not a bug in the application as the script was copied directly from the AAF to AirVantage tutorial we received from Sierra Wireless and I can see the other tasks from the app printed in the system log of the running device.

I am unsure where to go from here. Perhaps the application cannot be removed through AirVantage because it was installed locally? I imagine that should still be possible but at this point I am just shooting in the dark for ideas!

Hi Ian,

I get it!
How to fix:

  • Go in ACE Manager > Services tab > ALMS left tab:
  • In the MSCI section, Update server url with https://eu.m2mop.net/device/msci/com
  • Save and don’t forget to reboot the gateway.

M3DA protocol, like MSCI protocol use this url to communicate. Your account is on EU and by default the application is configured to communicate to NA server.

I’ve raised this issue to the Aleos AF developers.

Sorry for the inconvenience.



Thank you very much for the response! I had a feeling it was something simple like that I was missing, thank you very much for tracking it down!

I wonder why my account is on EU as I am in Canada. When I created it I was unsure why I was going to an EU link but assumed that it was the only option. I am going to look into changing my AirVantage account to NA instead as I assume all of the devices we will order will be set for NA.

Thank you again for all the help. I will let you know if I have success switching my account to NA and then communicating with the device.


I have not heard back from Sierra Wireless regarding changing my account from EU to NA but I changed the URL on my device and I can now successfully load apps onto the device and can now see the data model in the application widget.

Thank you very much for all of your help diagnosing my problem!