Error Installing AAF Application using ACE Manager

I have GX450 running the Firmware Version 4.9.3.002
I tried installing the .tar file containing AAF application using the new Install AAF Application option available in the web based ACE Manager. However I get failed to install application. The following is the error log I copied from the device.

err ALEOS_APPS_AAF-AGENT: In thread: 0x10dcc8: /usr/readyagent/lua/agent/update/init.lua:687: attempt to perform arithmetic on local ‘k’ (a nil value) stack traceback: /usr/readyagent/lua/agent/update/init.lua:687: in function </usr/readyagent/lua/agent/update/init.lua:670> (tail call): ? /usr/readyagent/lua/ltn12.lua:275: in function ‘step’ /usr/readyagent/lua/ltn12.lua:285: in function ‘all’ /usr/readyagent/lua/web/server.lua:336: in function ‘handle_request_body’ /usr/readyagent/lua/web/server.lua:154: in function ‘handle_request’ /usr/readyagent/lua/web/server.lua:115: in function </usr/readyagent/lua/web/server.lua:82>

1 Like

I have the same issue, have you solved it?

Hi oazrad,

Have you solved it?
I can install the .tar file containing AAF application on the web based ACE Manager successfully. I’m using GX450 running FW 4.9.4.p09.
Can you share your AAF application and Firmware Version so I can give it a try?

Thanks,

I’m pretty sure I’m seeing the same problem on my RV50X running 4.12.0.28. I don’t think it’s in my Lua code, since I can produce the same problem using the “Hello, world” app from the Getting Started tutorial. Also my app works find when I do a “Local Application Package Export” and send it directly to the RV50 from the Dev Studio AND when I export it as an AirVantage Application Package and install it via ALMS.

I wonder if it’s related to the platform: I’m using Win10Pro 64-bit with Oracle Java 8 Update 221 (64-bit) & ALEOS Developer Studio V2.0.0.201310251637.

Anybody else doing AAF development seeing this?

No. This is still not fixed for me.
I have updated to the latest firmware version available for GX450 (4.9.4 p09) as of today.

Hi,

Please make sure that the ALEOS Application Framework gateway in the web ACE Manager is enable.

You use the “Hello, world” app from the Getting Started tutorial. This sample app uses old AAF 1.0. Did you import this application to ALEOS Developer Studio V2.0.0.201310251637 or write new application?

I’m using RV50X FW 4.12.0.p31 on Win10Pro 64-bit with Oracle Java 8 Update 221 (64-bit) & ALEOS Developer Studio V2.0.0.20131025163.

I can export it as an AirVantage Application Package and install it via ALMS successfully.

I have attached my application and package on ALMS server for your reference HelloAirVantage.zip (2.7 KB) .HelloAirVantage-6.zip (2.0 KB)
You only need to extract and import my application to ALEOS Developer Studio V2.0.0.20131025163.

@msamitahir & @oazrad,
I (well, actually, a SW developer that was helping me:wink:) discovered that MY issue with installing the .tar file produced from a “Local Application Package Export” via the ACEManager “Install AAF Application” was caused by using https://:9443 to connect to the modem. Once we enabled HTTP communications for ACEManager and I connected using http://:9191, it installed just fine!!
Please let me know if this fixes it for you as well?

@ehgoodrich Thanks very much. I used http to login to ACEManager and it works.
PS : I have configured port 80 for http so it does not have to be port 9191.