Unable to run export

Hi Guys,
I have a very basic problem at the moment. We have just started playing with our GX400 and get to the point in the developer studio where we export the applicaiton (hello world) to the App Container on the GX400, but all I get is an error message “Unable to run export. Unable to get RPC connection.” We double checked we are using user uasuser and the correct password. Any ideas?



I don’t have a precise clue for know.
However could you give the version of the firmware running on your GX.

By the way, did you activate AAF on your device?
(You can do it using AceManager web UI and going to Application tab).


Hi lberthelemy,
Yep we enabled the AAF in ACEmanager. Our GX400 has ALEOS V 4.3.2a010



Unfortunately, I did not manage to reproduce the problem.
Can you provide us with a bit more information:

  • are you able to run and debug the application on the target ?
  • can you send us the log file of the IDE (the .log file in the .metadata folder of the workspace) ?


Thank you all for your assistance. The problem turned out to be that we had the 32 bit JRE not the 64 bit.
Once that was installed, everything worked fine.



I have the same problem trying to export my project to the device (GX440). I checked and I do have the 64-bit Java JRE. I have entered the correct password but I still get “Unable to run export. Unable to get RPC connection” when I try to export my project.

I have attached my log file.
.log (162 KB)

I also have the same problem trying to export my project to the device (LS300). I have try at two PCs one of them with windows7 x64 and another with windows 7 x86 with JRE installedc. I have entered the correct password but I still get “Unable to run export. Unable to get RPC connection” when I try to export my project.
Is curious because the problem only appear when I try to export to remotely device (conection by internet). When I try to tranfer the same device conected to my LAN all it is ok.
However when I only run the application without export it, all work ok both of two case (remote connection and local connection)
log.log (61.8 KB)

The “ALEOS AF Getting Started Tutorial” forgets to mention that in order for a device to export and run on a GX device, the device needs to have Aleos Application Framework Enabled. This tutorial does mentions how to enable it. See developer.sierrawireless.com/en/ … 20AA0&_z=z

Once I enabled this on my GX440, the RPC error disappeared and I was able to upload my application.

thank for your help but I have that feature enable and the problem continue.
I am using the same device, trying in LAN and WAN. In the first test works but in the second test using device conected by WAN doesn´t work appearing the RPC problem.

I have the exact same issue as hidrocontrol.
was anyone able to solve this?

WAN access can be more complicated than LAN access for many reasons.

Please check and report the WAN access to your device outside the context of AAF app export.

For example, did you try to connect and login to ACEManager using the same cellular WAN address?

If that fails too, it is likely that your WAN address may have restrictions: some celullar WAN IP are not accessible (the device can access the whole internet network but can’'t be contacted directly) or some port may be blocked etc.


lbarthelemy, thanks for you answer.

Yes, the ACEmanager works over WAN with no problems.
So at the beginning I was not even able to connect the connector under the “remote system explorer - developer studio for ALEOS”.
Later on I added a port forwarding under the security at the ACEmanager for port 22 for (that is the LAN address).
At that point I was able to connect via developer studio for ALEOS and look at the “Scp Files” folder and it content.
Unfortunately, when I go to the “App Container” I get “RSEG1058 connect to GX450 was cancelled”. And my connection is dropped.
Moreover, if I reconnect and go back to the Lua prespective and try to export my project I still get “Problem Occurred Unable to run export. Unable to get RPC connection.”

I would greatly appreciate any help you can offer.


Another protocol is used (in addition to ssh) to control the target. This happens on port TCP:1999. Try redirecting this port as well (the same way you did for the port 22).
Let us know if that helps.

BULL’s EYE :slight_smile:

that did it. port fw TCP 1999 to the same IP address of my LAN.

thank you :slight_smile:

Thx for the feedback!
Please note that the protocol on port 1999 (Lua RPC) is not a secured protocol, so exposing on the WWAN might expose some risks (i.e. someone could theoretically disable your AAF application).
The workaround is to disable the port forwarding rule once you have installed your AAF app and re-enable it when you need to change your app.

good point.