Export from Developer Studio for ALEOS

This problem has cropped up before, but rather than adding to an eight-year old thread , I thought it best to start a new topic.

I can run my own lua script via the IDE, but I am unable to export it as a package which will run on the MP70.

If I try to export as “Local Application Package” to the MP70 host address, I get an “Unable to run export.” dialogue box with “Unable to get RPC connection.” under ‘details’.

If I export to a directory it produces a .tar file which I have then tried to install as an AAF application using ACE Manager, but I get a “Failed to install application” alert each time I try.

Likewise, if I try to export as an AirVantage Application Package, I get a zip file which also fails to install through ACE Manager.

I’m using Windows 10 and Developer Studio for ALEOS Version :


I’d read the (friendly) manual if I could find it. The in-app help on my install comes up with an HTTP 500 error ( Error 500 PWC6033: Error in Javac compilation for JSP ).

As a consequence I’m just hitting things at random, hoping something will work.

I’ve still had no luck with the export functionality. I’m running Developer Studio with Oracle’s Java 8, Update 291.

Maybe an earlier version would work better. Is there a recommended Java version to use?

Here’s a little glimmer of hope. I’ve rolled back to Java 6 and I can now read the help files.

I’m still having the same problems with installing through ACEmanager or directly from Developer Studio. I tried the process as detailed in the help - going as far as copying the minimal script from the example given. Even that fails to work.

It appears the .zip file generated as an AirVantage Application Package should be installed via AMM, but my account doesn’t seem to have access to the software repository.

I’m still looking for any help or advice anyone here can offer.

Is the .tar file incorrectly formatted?

For comparison I looked at the contents of the .tar file I had generated using Developer Studio for ALEOS, which won’t install, and then the contents of the AMMER .tar file, which will.

My own .tar file simply contained a manifest and a directory containing the lua files and an installation shell script. The AMMER .tar was rather more complex in structure - wrapping that simple tar in another .tar file with further configuration files.

It looks like a development of the file format and I’m left wondering whether I should be using a newer version of Developer Studio. The version I have is linked to from https://source.sierrawireless.com/resources/airlink/aleos_af/aleos_af_studio/ which states “This page contains the latest ALEOS Application Framework Developer Studio” - however, since the page dates from 2012, it seems possible this would have been superseded by now.

Is there a better version of the IDE to use for an MP70 with ALEOS 4.12.0 ?

Good news! After going through the problem for an hour with a Sierra Wireless engineer, it seems to boil down to an unexpected incompatibility between my version of Developer Studio for ALEOS and the version of firmware running on the MP70.

I’ve updated the device and radio firmware to the latest version and I’m now able to install my .tar files without any problem.