Can't deploy application to device - stuck at 63%

I am using an AirLink LS300 trying to write a hello world application and deploy it to the device. I have followed the steps shown here … _hardware/

to configure the hardware via the ACEManager. I have also followed the steps shown here … g_started/

to install the Development Studio IDE and create a basic hello world app. I am able to connect to the device (Remote Systems Explorer -> right click on connection -> connect) but when I try to run the application it gets stuck. It starts at “Launching hello_world: 60%” and shortly advances to 63% where it hangs indefinitely. I have let it try to connect for about half an hour just to be … sure.

I have been able to connect over both USB ( and Ethernet (
I reset the LS300 to factory defaults and tried again with no luck.

I’ve installed the IDE on 2 machines (Debian, Win7) and see the exact same behavior, so that leads me to believe the issue may be with the LS300 config?

Has anyone seen this behavior before or have any suggestions? Did I overlook something?


Also perhaps relevant, I am unable to get working shell with SSH. I authenticate with user/12345 but the console only spits out “OK” and does not accept any of my input. I can’t do an ls, for example. Tried from linux/win7.
Sample Output:

login as: user
user@’s password:


Starting with ALEOS 4.4.2 (LS300/GX-ES/400-440) and ALEOS 4.5.0 (GX-ES450, RV50), there was a security policy change that is to deactivate AAF user by default. So the first things you need to do run an AAF application is:

  1. Enable AAF in ACEmanager
  2. Define a password for the AAF user in ACEmanager
    This is described in the link you provided, section “connect your device”: … othedevice

Note: user ‘user’ is unrelated to AAF (it only provides AT command over SSH (or telnet depending on the config)). The AAF user is ‘uasuser’, and it is deactivated by default (or after a factory reset)

let us know if that works out.

Hi Cbugot,

Thanks for the reply and for the information. With your help I was able to upload the program.

My issue was operator error. I was connecting (through the IDE) with user/12345 when I should have been using uasuser/(AAF P/W). I clearly missed that in the getting started tutorial despite it being pretty obvious. I assumed I was on the right track when I successfully connected with the user account and never thought twice about it. I cleared all the passwords and tried the uasuser account and it worked right away.

Thanks for your help!