LX60 not connecting to network

We have a private LTE network and I am trying to connect my LX60via NBIoT and I’m seeming to have some trouble. We enabled NBIoT on our core and its not seeing the device trying to register. We utilize Band 2 1900Mhz. I purchased a LX60(NA) and was able to connect it via LTE but when I tried the LX60 Global it won’t even connect to LTE let alone NBIoT. We have tried all configurations. I updated to the latest software and firmware. I also performed a factory reset and still nothing. I’ve used this SIM in previous known working devices. Successful with an RV55. Our (MNO)partner did mentioned they got the exact same device working in their lab with older software and wondering why the newest would work or we need to revert?

Software LX_4.17.1.005.bin
Firmware WP7702_02.36.08.09_GENRIC_001.079_000.iso

LX60NBIoT ESN 356050090123949

Antenna
Quectel 2958-YB0008AA-ND(worked with other devices and on that freq)-88RSRP where we were testing.

Hi @josh.herman,

Welcome to our community!

  • Please make sure you have attached antennas to the LX60. Two antennas are required when connecting to an LTE network.
  • Do you have any other devices that can successfully access the NB-IoT network? The RV55 connects to the LTE network, while the LX60 Global uses NB-IoT, so they cannot be compared.
  • Has the APN been configured manually or assigned automatically?
  • Please share the log file and template file with me.

***Here are the instructions for obtaining the log file and template file:

  1. The configuration template file can be found in ACEmanager → Template. Provide any desired name for the Template Name, and then press Download to retrieve the template file.
  2. Obtain the log file:
    a. Go to AceManager > Admin > Log > Configure Logging.

Set all log levels to DEFAULT (NOTICE).

Set Linux Syslog to DISPLAY.

Then select Apply.

b. Reboot the gateway.

c. Go to Admin → View log → Download Logs.

Thanks,

This model of LX60 only has 1 cellular SMA connection possible
image
This is the first device we tried connecting to NBIoT because we have had success with Sierra devices previously we selected them but I think I will be trying a Microhard gateway if this doesn’t work. I understand the differences between the RV55 and LX60 Global. We were able to connect the LX60 NA to the LTE network and not the LX60 Global which is a comparable difference.
I’ve tried configuring the apn manually and have it assigned automatically.
I’m hoping the device keeps its previous logs as I tested it on May 3rd although the date/time in the logs all show Sept 8th. I’m attempting to upload the logs but apparently new users aren’t allowed?

Hi @josh.herman,

Please upload the log file and the template file to Google Drive and share the link with me.

Thanks,

Hi @josh.herman,

How did you perform the upgrade of radio module firmware? Was the upgrade successful? Did it hang or have any issues during the upgrade process?

Because I notice that there are many warnings: Radio module is disconnected, RADIO_STATE_DISCONNECTED_WAIT and RADIO_STATE_DISCONNECT in your log.

Which carrier provides the private network? Is it a real network? If not, please use a SIM card from the carrier on a real network and try to connect again to see if the issue still occurs.

Thanks,

Through the Aleos GUI. It failed the first time because I tried going straight to 4.17 from 4.15 and didn’t see the note that said you have to upgrade to 4.16 first. After that it was successful in both the software and firmware upgrade. Our company provides the private network. We work with an MNO that has subordinated the spectrum from a Carrier in Band 2(a well utilized frequency in our area). Its a “real” network with thousands of devices on it, including quite a few Sierra made products. I can try to obtain a SaskTel SIM to test but this shouldn’t matter.