Locked Fastrack, with 'fault 04' after software upgrade


#1

Have tried upgrading fastrack M1206B modem (Q2406B inside) with 657f000 binaries and associated downloader software.

I do +CFUN=1

Then +IPR=115200

Then +WDWL, & Xmodem the downloader dwl.dwl file.

All goes well thus far.

Then I select the Q2406B.dwl file and it downloads, and I end the session with CFUN=1

The modem reboots but stops immediately, reports ‘Fault 04’ and the CTS line seems to be permanently pulled low.

I hear the onboard SMPS whine for a fraction fo asecond and then it halts, obviously the unit is crashing out, but how do I restore previous versions now, or even get the modem working correctly ?

Tried this with 2 seperate modems and got the same results. I’m using a cable which has RTS and CTS connected

Any help much appreciated
Chris Barron


#2

Despite reading your posting before I attempted an upgrade to my M1602B modem, I have experienced exactly the same problem as you describe. I followed the procedure to the word, double checked everything - upgraded dwdl loader picked right firmware. Uploaded completed fine and following reset the modem will not communicate.

Can anyone help please!