Is there anyway to rescure a bricked EM7455?

Hi everyone. thx for view.

apologetic for my poor english first.

Here is the problem, i got a laptop x270, TYPE:20K5, MTM: 20K5S27Q07

i7-6500u/16GB/1TB nvme 2280 in the 2.5’’ solt, OS is Windows7 SP1 64bit.

This laptop have a M.2 2240 WWAN Solt, so I check the lenovo support for 4G Module whitelist, then brought a Sierra EM7455 4G Module with FRU:01AX748. And download the driver file nz1wl05w.exe from Sierra Wireless EM7455 Software for Windows 8.1 (32-bit, 64-bit), 7 (32-bit, 64-bit) - ThinkPad - Lenovo Support US

But I made a wrong operate, the driver nz1wl05w.exe is made for x260’s EM7455, maybe it can’t work properly on x270.

So when I install the module, start OS ,everything is OK at first, new modem found by Windows Device Manager, nz1wl05w.exe runs about 30sec, a small block appeared at lower right corner, looks like it’s updata the EM7455’s firmware, and tells “donot shutdown or reset the computer”. But the flash progress is too long(about 2min), and halt in 92%, then a error message “error 67”, the whole driver installtion is over.

I checked Device manager, but the EM7455 was disappeared.

I tried restart the computer, unplug and plug the module, updata the X270 BIOS(It’s up to data now),Reset BIOS Setting, ReInstall the OS to win10, DISABLE/ENABLE the Wireless WAN in BIOS, it’s all not working. Device Manager can’t detect any thing about EM7455 now, no modem, no port like QALoader, no Network Adapter can be found.:(

So is there anyother thing I can try?


Something new 1:
I tried flash the firmware with fdt.exe/ fdt2.exe from Sierra site, but they won’t work, programme failed in check modem mode and exit.

Hi @longlongago
Do you see any port of device under Device Manager page? Please share with me screenshot of the Device Manager tab (Modems, Ports (COM & LPT)).


Thx for reply jerdung.

Unfortunately there is no port device in DeviceManager now.

Only one item looks like modem is a “Sierra Wireless Location Sensor” under Sensor. But when I shutdown the laptop and remove the module, and restart system, this device still there.

This is a chinese system, so I made some notice on picture.

Hi @longlongago,
it sound like you have the OEM drivers and connection manager running on your PC, this driver forcing to download the OEM FW version into EM7455.
you should remove the existing Sierra Wireless drivers and tool, and install this drivers from Sierra source website.
then restart your PC and you should see in COM ports list at list two devices and also modem device (this is the AT command port, you can see it on the modem properties).
after it I would recommend to change the USB composition to MBIM interface to run smoothly with Windows OS.
Open the AT command port with TerraTerm or other terminal and type the below commands.

after it, the EM7455 should up as standard cellular module and you can set it by Windows cellular settings.


Hi @elkanam ,thx for your reply.
Follow your link I got a file named GenericDriverSetup_5087.exe. Then I uninstall the lenovo driver pack, restart windows, install GenericDriverSetup_5087.exe, and restart the PC again.

Unfortunately after these steps, there’s still no new device detect by device manager. The windows device manager still have no modem and Ports(COM&LPT) properties.

Anyway…thank u ,and anyother suggestion is welcomed.

Hi everyone, problem solved.

This issue maybe triggered by the Thinkpad 's whitelist. Maybe thinkpad bios block the access to module after firmware updata failure. So I can’t see any device under device manager when I insert the module to M.2 WWAN solt on x270’s motherboard.

So I bought a USB TO M.2 WWAN adapter. As expected, EM7455 is visible through USB port. I can see port device in DM, and I can rewrite the firmware. When the firemware back to normal, it’s also visible in x270’s M.2 solt.

Hope this topic is helpful to anyone like me:)

1 Like