Bricked MC7455 Module in a Dell DW5818 WWAN card after trying to update the firmware!

Never posted on here before, but couldn’t get any help from DM to S/W
I have a Generic MC7455 out of a Dell 3001 Gateway.
Unit had failed in the field and was contactable via windows COM port.
After looking around and found as much information as i could, i decided to upgrade FW to 02.38 (from 02.32) located in the S/W downloads area.
Windows upgrade looked to work, all the text, flashing lights etc.
Now the unit only shows up as a “Network Device” and I am unable to access it via the COM port.
It does not show up in any other devices list.
I have obviously bricked it, and have ran out of knowledge in my little brain.
I have tried many different FW versions afterwards, along with different windows drivers.
Linux will be my last resort, but even thats a learning curve for me.
Any advice or ideas - other than throwing it away, as i would like to be able to get back into to prove that reloading the FW would help fix it.

You can see here: (open Configuration.ini and change “USBCOMP=8” and run the driver setup )

I have the same thing, my 7455 modem does not see com ports and installed USVCOM-8 does not help. Something else is needed, it would be nice if those support did something, or rather came up with a utility that would fix the cause

What did you see in device manager

Managed to fix it.

Referencing to the following site:-

I loaded the ubuntu image onto a USB as described here, booted up and selected “Try ubuntu without installing”

Followed the details.

You may need to edit the file to read your modem port (line 16). I had to change from dev/cdc-wdm0 to dev/cdc-wdm2
I saw that my modem was set to “Current USB Composition:9” and needed it to read 8.

The difference between the 2 modes is 9 will only give you use of MBIM, but 8 gives access to DM, NMEA, AT, MBIM

Checked the current settings using command

Followed by the command
./ –-usbcomp=8

Moving back to my Windows machine I could see there was a device in the Device Mananger > Modems
You should be able to access the Modem COM port through Putty etc, to change/look at any issues.

The main issues I had that caused this all along was the Modem had been out in the real world working happily for a couple of years, then stopped working.
After access it through Putty, noticed lots of parameters were different from a working Modem, I tried a reset with AT commands, which managed to destroy the IMEI number.
So not knowing what to do next, upgraded the FW with Sierra Wireless FW updater to 02.38 from 02.32.
This is where it all went south and lost total communication with the modem and would only see it in Network Adapters (No COM port access)

So suspect the FW 02.38 (Generic) was the cause of the block.

I hope this helps others.

This is information I got from other sites, but what works for one person may not work for another.

Shows everything and there are no com ports, everything installed the driver did not help

Do you see any network interface?

I bought one of the following cards to plug the MC7455 into my USB port.

you will have to download, burn & run the linux USBboot, as that was the only thing that worked for me.

Once you are in linux if you type mmcli -m 0
this should give you some stats, even if most of them are not correct.
you may have to change the -m 0 to -m 1 etc.
you are looking for dev/cdc/wdm0 or similar
this should show a Sierra Wireless device - if it does not , there’s a pretty good chance your modem has a hardware failure/ voltage spike etc.
With most of the PCI-USB adapters if the modem is being seen correctly by the system a solid blue LED will be seen.

Is through windows or linux?