EM7455 Firmware Flash

Hello all I was hoping to get some help it may be possible I bricked my EM7455.

In windows 10 I tried installing generic drivers/firmware

I waited about 20min and nothing seemed to be happening so I unplugged and re plugged the adapter.

here is what I see

I can’t access the ports and It fails to flash the firmware


Have a good day. I’ve MC7455 module and no issues on latest firmware flashing on windows 10. Could you elaborate more about any specific errors ? Either drivers or other factors.

The error codes in device manager are code 10 device cannot start.

I have tried to flash with generic firmware with and without skylight active with skylight active I see updating firmware and then it changes to download failed.

I did a ubuntu install on a flash drive to try a method to open the ports using ./swi_usbcomp.pl but that returned file/ directory not found.

I can see the EM7455 in ubuntu with the usb display command it does give the PID ID and such which is 1099/0907

I cannot find the ./swi_usbcomp.pl in ubuntu.



Have a good day. Based on that information that current module firmware was corrupted BUT luckily still showing that hardware address via ubuntu which means /dev/ttyUSB0 should be shown. You get that file from below website.


That’s not a good idea… I’ve modified that document just in case.

This says it’s for the MC7455 I have the EM7455
dl5162 You say don’t do this?

Any other suggestions?



Have a good day. I’ve MC7455 module which currently at "boot and hold" status (Bootloader) and try to flash latest firmware through Ubuntu via third party tools (qmi-firmware-update) but got problem. Actually MC7455 and EM7455 are same but only different on module configuration. You can use the same firmware for both. Based on information from sierra related website, flashing firmware could be done via Sierra specific SDK from below website.

source.sierrawireless.com/resou … 00,-d-,07/

But I haven’t tried yet.

I have downloaded and ran tar on the SDK however I do not know how to compile if needed or install could someone explain how to install? I am using 16.04 LTS I can install a newer version if that will help.

I ran tar from the download directory however I do not know where the extracted files went or if I need to run make to build or just tun install. My Linux is very rusty.



Have a good day. I’m also new for Ubuntu (5 cents) where currently running Ubuntu 17.04 (64 bit) on DELL E7240 and MC7455 module. You should go through that related manual (Linux QMI Application Developer Guide) where it stated all related commands and syntaxes. No need to recompile “slqssdk” because that “slqssdk” is already in binary mode. Under sub-directory “SampleApps” you can see another sub-directories as below:

zabo5515@zabo5515-E7240:/work/SLQS04/SampleApps$ ls -al
total 56
drwxr-xr-x 13 zabo5515 zabo5515 4096 Mac 8 15:08 .
drwxr-xr-x 8 zabo5515 zabo5515 4096 Apr 10 02:42 …
drwxr-xr-x 8 zabo5515 zabo5515 4096 Mac 8 15:19 AirVantageAgent
drwxr-xr-x 5 zabo5515 zabo5515 4096 Mac 8 15:17 CallHandling_Application
drwxr-xr-x 6 zabo5515 zabo5515 4096 Apr 21 08:41 Connection_Manager
drwxr-xr-x 6 zabo5515 zabo5515 4096 Apr 21 08:40 Firmware_Download
drwxr-xr-x 6 zabo5515 zabo5515 4096 Apr 21 08:53 Gobi_Image_Management
drwxr-xr-x 5 zabo5515 zabo5515 4096 Mac 8 15:17 LOC_Service
drwxr-xr-x 5 zabo5515 zabo5515 4096 Apr 21 08:38 MC7xxx_Image_Management
drwxr-xr-x 5 zabo5515 zabo5515 4096 Mac 8 15:17 PDS_Services
-rw-r–r-- 1 zabo5515 zabo5515 1447 Mac 8 15:08 SampleApps.mak
drwxr-xr-x 4 zabo5515 zabo5515 4096 Mac 8 15:17 SLQS_Tutorial_Application
drwxr-xr-x 5 zabo5515 zabo5515 4096 Mac 8 15:17 SMS_Application
drwxr-xr-x 5 zabo5515 zabo5515 4096 Mac 8 15:17 SWIOMA_Application

I believe you need only these sub-directories (BOLD) then just run “make” then it compiles accordingly.

Your issue looks like a simple WIndows driver problem to me. You should primarily try to solve it using the Windows driver installer. It does take a few options which might help. Doing all sorts of magic stuff in another OS comes a bit further down on the list of things to try :wink:

dl5162 I have tried all the tricks I can in windows I tried deleting all the drivers directories and registry entries. I have tried reinstalling the drivers. I extracted the exe file for levono drivers and used ftd to install them. I tried the “modemfix” I don’t see any other ways to do this in windows. If you have suggestions on another method please explain!


There are two possible ways to solve a windows driver issue: Either switch the modem configuration into something matching your drivers, or install drivers matching the modem configuration. Deleting stuff or running fdt will not achieve either, and is therefore futile. Running arbitrary commands without knowing what they will do is how you got into the problem. Unfortunately it is not the way to get out of it. You may instead end up with bigger problems.

I still suggest running the driver installer you already ran from the command line, and with options. “/?” is a good start. See the instructions here:

Note that you should use the newer driver version you already have been using, not necessarily the old version referred to in that old thread. And don’t do anything else mentioned in the same thread. It was a long evolutionary thread. That single post represents the final outcome.

My guess (could be wrong - you haven’t told us) is that what you want is to configure the modem for MBIM so that it works out of the box with Windows 10. That means that you would do something similar to this:

GenericDriverSetup_Build4581.exe WIN8BUSDriver=1 USBCOMP=9

Now, the chances are good that it won’t work at all, since I have no idea what state you modem currently is in or what state you expect it to be in. But it is a start. And should tell us something. Please post the output from the commands you run.

Ok I ran a clean install with the command GenericDriverSetup_Build4581.exe WIN8BUSDriver=1 USBCOMP=9 and this is the result.

Well, I asked for the output not the result. But anyway. that looks good doesn’t it? Except that it hides the modem behind the “network adapters” I guess. No idea what that PCI serial port is, but the modem isn’t a PCI device so it has to be something else. All the other devices appear to have drivers attached, so then I guess you are good to go.

But we are still guessing a lot here. Not much useful info in those pictures, is there? No device IDs, no interface numers, no class codes, no driver info. Nothing really. I enjoy guessing, but it’s not particularily productive in the long run.

Hey what’s all this stuff? Haha Doope Thanks Man!

At least I’m back where I started from.

Now I still cant AT into the modem which is what started this mess in the first place.

How do you open that com port so you can give the modem AT commands?

Ah, so that was what you wanted. Running the installer with USBCOMP=8 instead will enable the serial functions in addition to MBIM. But these are vendor specific so they need a vendor driver. Which is supposed to be in that package. But that depends on the modem using the Sierra VID:PID. If it doesn’t, then you might need to adjust the Windows driver .inf file to make it work.

Someone familiar with Windows will probably be better at explaining this than me :slight_smile:


I believe no issues for that module because in serial port only shown DM and NMEA ports together with modem, network and USB ports. Actually “AT” triggering via DM port where can be access via windows “HyperTerm” or “Putty”. If no DO port then that module got issues. Through Ubuntu you can access that module modem via “minicom” and that modem port normally “/dev/ttyUSB2”.

Ok here’s what I did I don’t know if it’s proper or even useful for anyone else but this is how I got the EM7455 to work.

I borrowed the first half of this hack here zukota.com/sierra-wireless-em74 … vo-laptop/ to get access to the modem. I changed the PID to 1199 9070 from 1199 9071

I was able to flash the new generic firmware

but still no joy

Then I did the last half of another hack (I can’t find the link now lol)


And poof! (see first image)

After that I loaded the build 4581 drivers and it worked!


I couldn’t comment on your findings because currently I’ve EM7455 and MC7455 modules and installed on Lenovo X220/X220T and DELL E7240 running Windows 10 Pro 64 bit respectively without an issues. Both modules are bought from Mainland of China. But I’ve a problem to install MC7455 on Lenovo X220 running Windows 10 Pro 64 bit where this module was brought up only at “boot and hold” mode which means waiting for firmware flashing. As far as I know at present current Sierra Firmware Flash Tool (fdx.exe) couldn’t be used and can be resolved through linux via Sierra SDK tool or third party tool (qmi-firmware-update), BUT I haven’t tried yet because from website too much related information and becomes questionable …