EM7455 Flash

Hello Hello,

i try to flash my new Batch of 100x EM7455 but it doesnt work. I tried every Single Version but no succes.
Is there any way to flash the LTE Modul? And sorry im Really new to this, so please be patient with me.
If you need some more information, just ask.

For every help im very greatful

Thank you

how about running the “AT!BOOTHOLD” first?
It should then enumerate a DM port only in device manager, and then you can run again the exe or fdt tool to upgrade FW.

Hello, thank you. But can you explain it a little bit more?
Because i dont now what do you mean.
Thank you very much

Do you have modem port in device manager for communicating by AT command?

No i dont have it in the Device Manager.
I thin i have to start from the very beginning.

You can see here to get back the modem port:

Okay thanks i will try that, and then i will give you an update.


now this one show up in the Device Manager, but it seems not correct.
Did i something wrong?

I installed the Driver 5087 with the Configuration and tried both ways USB COMP 8 and 99

I saw there is modem port, but not sure why the driver is not installed properly.
Have you tried another usb port?

Have you tried another windows pc?

yes thats strange, tried every USB Port, now i will try another PC. I will give you an update then
Thanks for your help.

sooo… still the same Problem, is it possible that my USB M2 adpater is not working correct?
Or is there any other way to install it?
I have more than 100 LTE 7455 Moduls, but still the same Problem.

did you see problem in linux PC?
If yes, probably this is your adaptor problem

Can you show me wich adapter should work?
I dont have much experience with Linux.

i don’t use M2 adaptor, I use the EM7455 dev kit.

can you double click the modem port and see why there is installation problem in device manager?

Which Dev Kit do you use?

In the Device Manager it says, This Device cannot start Code 10
The reqested operation was unsuccesful.

I used this development kit:

can you update the driver?

You need to use 7zip to unzip the Driver 5087

Thanks for the Information.

After Clicking Update Driver, it shows or says the best driver for your device are already installed.

then why it still show like this?

I have no idea, this is my setup right now. I will buy some other Adapte or the Dev Kit. Maybe then it will work, or do you have something else in mind what i can try. :open_mouth:

I suggest you to ask a linux engineer to try in linux pc