Import projects from older SDKs


#1

M2M Studio allows you to import older SDKs - it successdully (it says) imported the Open-AT v4.24 and v3.13 SDKs for me.

But how can I import projects from these SDKs?

The “IDE V1” import option doesn’t recognise these projects. :angry:


#2

Did you try the File > Import > M2M Studio > IDE V1 Project wizard?
By making it point to a IDE V1 project folder (the one where you have the .scs file), it works fine…
Some things are missing (e.g. symbols defined with -flag option), but globally it works.


#3

I didn’t access it via that route, but it was the IDE V1 wizard (straight from the M2M Studio start page, IIRC).

I’ll check to see if that route makes any difference…


#4

I tried it again - this time it worked! :smiley:

But it was via a slightly different interface.

I think this is an inherent “feature” of Eclipse, rather than M2M studio specifically - the way that there are different routes to end up at similar (but not quite the same) functions, and it can be difficult to find the same route twice! :confused: