M2M Studio 1.1.1 is available for download

Dear M2M Studio users,

M2M Studio 1.1.1 release is available for download on the website at http://www.wavecom.com/m2mstudio
For more information on this new release content and installation/upgrade instructions, please refer to the release note at http://www.wavecom.com/releasenotes/m2mstudio/1.1.1

Enjoy using M2M Studio
Thanks and Regards.

can i use my existing workspace, or do i need to re-import my existing projects?

It depends if you plan to go back to the old M2M Studio version with this workspace or not. Indeed projects are converted when opened with M2M Studio 1.1.1, and also become not usable anymore with older version after that.
The safest way stays to start with a empty new workspace, and to import old projects (with clicking the “copy” checkbox) in it.

Another subject you have to take care is the Open AT software packages.
In 1.1.0, they are colocated with M2M Studio installation dir, in the dropins subdirectory.
With 1.1.1, by default it is the same, but you can choose another location to start sharing installed packages between several instances of M2M Studio. Please refer to the Package Manager help to know how to do. However, whatever is the location you choose for your installed packages, you can get the ones you installed in your old M2M Studio 1.1.0 install by just copying the content of the dropins folder to the new packages installation folder.

This download doesn’t include any Open-AT Suite, and this is not clear from the downloads page: when it says, “full package”, that could easily be taken to mean that the Open-AT Suite should be included - since M2MStudio without it is not much use and, therefore, can’t really be considered a “full” package.

Especially in the light of the way all the publicity goes on about M2MStudio being, “everything i [/i]you need…”

So I downloaded the “full i [/i]package”, installed it - and found that it does not, in fact, include any Open-AT stuff. :frowning:

So I downloaded the “Open-AT Software Suite v2.31”. But, when I install that, it insists on installing M2MStudio v1.1.0 :exclamation: :angry:

So how do I import the Open-AT Software Suite v2.31 into M2MStudio v1.1.1 :question:

There is no longer an ‘Import SDK’ button, and the “help” i [/i]for “Software packages installation” is meaningless to me!

BTW: the PDF documents are still not in an easily locatable place- they are buried deep in C:\OpenAT\OAS231\M2MStudio\1.1.0.200908120848\m2mstudio\dropins\com.wavecom.openat.ide.spm.lib.os.model.6.31.0.03\resources\doc :angry:

I’ve installed M2M Studio 1.1.1 -> Imported a M2M project form previous M2M Studio -> Opened properties of the project -> clicked Package Import Wizard under Open AT Application.
After that there is a way to import SDK just as any plugins not included in the SDK i.e. C-GPS for OPUS I

jacfry

it still helps to review the help for the package manager.

it took me some searching and double reading, but:
open perspecitve:
Package manager perspective
-> click add new repository ( on the bar with available packages)
-> click archive
-> choose browse ( then […] button)
browse to the [OpenATSoftwareSuitev2.31.exe] file
then choose what to install.

Hi,

Has anyone got the update or install features to work yet. I get “cannot complete the request”, “this installation has not been configured properly for software updates” with selecting either Help->Check for Updates or Help->Install New Software. It seems this might, or might not, be an Eclipse problem – searching for those exact strings on google gets a number of replies that are sort of the same problem. The suggested fix – a line inserted in config.ini doesn’t work here – that file isn’t present. It does seem the problem is fixed however – if I could get the update… No – the autoupdates don’t work for other than Wavecom supplied code.

Regards,
Gavin.

I tried, but it was total gibberish to me! :confused:
It is clearly written by an Eclipse expert - but I am not an Eclipse expert, and have no interest in becoming one!

All I want to do is to get on with developing Open-AT Applications (which will sell Wavecom Product) - I shouldn’t have to be messing with the guts of the tools!

In the pre-M2MStudio days, it was all just done by the Wizard; in the previous M2MStudio release, there was a button to do it.
This is definitely a retrograde step!

Exactly - since this is so absolutely fundamental to getting any actual Open-AT work done, it needs to be made much more accessible!

Yes, that part was easy enough

The help doesn’t even show what the correct button icon is.

And what is a “repository” - why should I want one?
It asks for a name - what should I say?

The nomenclature is confusing: the button is called ‘Add Repository’ - which suggests that a ‘Repository’ is the thing that I’m creating;
But then the dialogue suggests that the “Repository” is the thing that I’m importing!

The help just says, “This repository can be either a directory, a ZIP or EXE archive” - which is unhelpful!
A “directory, a ZIP or EXE archive” could contain anything - it needs to specify that this is the Software Suite!

Again, the nomenclature is misleading!

The contect menu says, “Install selected packages” - but it is no possible to make the selection until after you have selected that option!!
So it should say, “Select packages to install”

Definitely zero out of ten for usability!

…yet
We are currently in a transitional phase, but in the coming weeks, the new Software Installer you used to setup M2M Studio 1.1.1 will also be able to download and install Open AT Software Suite and Windows Drivers.

Excellent! :smiley:

But I think the help - at least - still needs some work for people who will need to import other Suites…

About the config.ini file, in M2M Studio case it is replaced by m2mstudio.ini
However, please elaborate about your investigations in a new topic.
Thanks.

Your (long and full of suggestions :wink:) post has been logged. The Package Manager help & tutorials will be reworked in future release.
Thanks for your feedback.