How to run sample with WIP in RTE


#1

I got a fresh installation of the M2M 1.1.1 using Light Installer then tried to build in RTE the sample “tcp server” that uses WIP but it didn’twork.
In the trace box I can only see “Embedded Application : Main” and the modem didn’t get connected to gprs network.

Anyone can help me?

thanks.
Gualtiero


#2

Does it work in Target mode?

Standard debugging approach: eliminate the possible causes…


#3

Hiya,

There’s a whole lot of stuff that doesn’t work correctly (or at all!) in RTE mode - mostly where interrupts are used. Have a look through the ADL doco to make sure that what you’re trying to do is not forbidden in RTE mode.

ciao, Dave


#4

In target mode it works correctly.


#5

Ok, I’ll look into docs but with the release 1.0.1 and firmware r73 I can run it without any problem. Is it possible a major changes in RTE from 1.0.1 to 1.1.1?

bye,
Gualtiero


#6

No major change from 1.0.1 to 1.1.1 regarding RTE mode.
Are you using the same WIP version than the one you were using before (when it was running)?
If not, maybe you should give a try to restore the same project configuration, but using M2M Studio 1.1.1
If it’s still not working, the issue may be in M2M Studio 1.1.1
If it’s working, then maybe the issue is within the WIP plug-in itself…