GX450 reverting to factory defaults on its own

I have had an Airlink GX450 modem revert to factory settings on its own… Has anyone have this happen to them before? It reset completely… IP, password, EVERYTHING…
The modem is inside a digital sign that is extremely difficult to access without proper tools and trucks so I don’t believe it was done by pressing the button.

ALEOS is 4.5.1 build 009

Hi @nmcwilliams ,
Are you able to log in ACE Manager after the device was reverted to factory? Can access If this is the first time you set up the device. Please go thru the Software configuration guide for more detail
Document: https://source.sierrawireless.com/resources/airlink/software_reference_docs/airlink-aleos-configuration-guide-for-gx450/#sthash.DDoAnPXX.dpbs
Aleos 4.5 is very old so please consider to upgrade latest for more functions supported
Latest FW: https://source.sierrawireless.com/resources/airlink/software_downloads/gx450/gx450-firmware-list/#sthash.u43YfRjA.dpbs

Please share if you have any concerns. Help us tick “Solution” if it is useful. It might help someone getting same the problem

I can log in, that is how I know it reverted back to factrory…
I tried to upgrade to without success.
I also tried changing settings and adding port forwarding but they all reverted back to factory.
I am going to presume at this point that this modem has gone bad.

Hi @nmcwilliams ,
Good to hear that the gateway is OK now. Pls share if you have any concerns