GX450 Network LED flashing amber/red

I’ve just configured a brand-new GX450 (Verizon), and while it is working, the Network LED is flashing amber/red alternately. I checked the manual that’s available online, and there’s no description of this state - only flashing red. In this instance, using firmware 4.5.1, the device is on the network, and reachable remotely.

Is this a new indicator of some kind? If so, what is it telling me? The modem is acting just fine, only flashing unknown LED patterns.

Thanks in advance!

1 Like

In the hardware user guide ( http://source.sierrawireless.com/resources/airlink/hardware_reference_docs/airlink_gx_series_userguide/ ) , itismentioned that ‘Flashing Amber’ indicates ‘No Service’ and ‘Flashing Red’ indicates ‘Authentication/Negotiation failed (EV-DO only)’.

So even after the modem registered to network, you can see the Network LED is flashing amber/red alternately? If it’s registered, then in which service?


Yes. Modem is fully functional (VZW), 4G mode, excellent RSSI, RSRP, RSRQ, shows device is Network Ready. Other than the alternating amber/red Network indicator LED, the modem is acting as it should. I am running version

Mar 3 15:41:22 alert ALEOS_SYSTEM: _ _ _ _ _
Mar 3 15:41:22 alert ALEOS_SYSTEM: / \ / \ / \ / \ / \
Mar 3 15:41:22 alert ALEOS_SYSTEM: | A | L | E | O | S |
Mar 3 15:41:22 alert ALEOS_SYSTEM: _/ _/ _/ _/ _/
Mar 3 15:41:22 alert ALEOS_SYSTEM:
Mar 3 15:41:22 alert ALEOS_SYSTEM: Sierra Wireless
Mar 3 15:41:22 alert ALEOS_SYSTEM: Copyright 2009-2015
Mar 3 15:41:22 alert ALEOS_SYSTEM: Version:
Mar 3 15:41:22 alert ALEOS_SYSTEM: Single Code-Set
Mar 3 15:41:22 alert ALEOS_SYSTEM:
Mar 3 15:41:22 alert ALEOS_SYSTEM: Serial no: LA53830056001003

Also, this issue is currently isolated to firmware 4.5.1. I have a modem running firmware and it’s LED pattern is normal. As soon as I upgrade to 4.5.1 - the flashing LED begins.

I’m seeing the same thing. Modem is working fine and network is good but the Network LED continuously flashes from red to amber, red to amber, etc. Is this a known bug with this 4.5.1 firmware?

Same thing here. Brand new GX450 worked as expected with 4.4.2 but as soon as I upgraded to 4.5.1 the network light blinks amber/red. Still functions just fine but makes you think there is something wrong. I am new to the forums… Are they monitored for issues or should I call it in? It’s nice to have the LED’s functioning properly for quick diagnosing.


As you guys have seen, upgrading your GX450 unit to 4.5.1 will cause the Network LED to flash amber/red. This is normal. The flashing LED indicates that there is currently no Radio Module Firmware (RMFW) installed in the local store. The GX450 can hold up to two RMFWs in its store, and is used to accommodate a feature called ‘Network Operator Switching’ (that is, to switch between different carriers - Verizon to AT&T, T-mobile to Sprint, etc). Until you install a least 1 RMFW, the Network LED will keep flashing amber/red. The local store can be found in AceManager > Admin > Radio Module Firmware.

Now, if you had a Verizon SIM, then you would want to download the GX450 Software Package for Verizon. In that package, there is an image file called “MC7354_VZW_55581.iso”. Install that through the local store. And if you choose to use an AT&T SIM instead, then you would want to download the GX450 Software Package for AT&T and do the same thing. After installing the two RMFWs, the modem will locate the appropriate one to use based on the SIM card inserted. Essentially, a Verizon SIM or AT&T SIM won’t work unless the correct RMFW is installed. After inserting a SIM, all of the LEDs will begin flashing rainbow and will connect to the network once the “switching” is complete. If you use a custom APN, then you would want to enter that in the modem after the switching takes place. Otherwise, it will look for an APN to use in its radio. At this time, the Network LED will no longer flash amber/red, as a RMFW was detected in the store.


Hi Nick,

Wouldn’t it just be simpler if as part of the upgrade process you simply fork a process to store a copy of the running RMFW to the Local Store? This just adds yet one more configuration step for each and every modem requiring setup. Since our network is a Verizon Private Enterprise network, and we can’t use the automated cloud-based tool due to security concerns - we now have some extra work tacked on. How long does it take to write this file to the local flash memory? Remember, multiply the time by at least 100x (number of devices I regularly purchase) and that adds up to the amount of extra time now wasted to fix a “problem” created in the Sierra labs.

Also, when I purchase the modems, I buy them as GX450 VERIZON devices. Right there it should tell you that it’s a single FW device. And, accordingly, populate the local store. Maybe have manufacturing include that in the base build for such devices.

I’ve been struggling with these modems since the very earliest GX-440 modems that were failing at a 25% rate at first. Once FW 4.3.6 came around, things stabilized a bit. Now with the GX-450, I thought things would get even better and less annoying.

Nick, just came on this problem, thanks for the info, worked perfectly.


I have the same issue on a gx450 running 4.9.6 (008) and can’t get a rmfw to install. The Verizon package available on the sierra support site is a spk file and the GX won’t take it as a firmware package.

Any advice?

Hi Smohr,

I think you may be looking at a firmware file for the dedicated “AirPrime” modules which are usually .spk.

For the “AirLink” devices (ie, GX450), RMFW images are in the form of .iso files, not .spk. Here’s a link with the latest RMFWs for the GX450.



Thank you so much. I was trying to unpack the iso and upload the individual file to the device. I even burned a CD and tried that route. Just tried again using the .iso as the selected file and it worked perfectly.

Thank you so much!