Red Flashing Network LED

RV50 worked fine until last week when suddenly the Network LED flashing red. Replaced antenna and cable, still red flash. Took modem to an area where there is confirmed Verizon signal, still the same red flash. Power button green, signal soemtimes green, sometimes amber. I looked at the forum and noticed others with similar problems and NO solutions. I have two more RV50s that have developed this issue in the last one year. These were bought in 2017, 4G. Any way these can be revived without a hefty repair bill ?

Hi @asaha ,
Which FW are you using? Sierra has delivered the new Aleos 4.14 at the beginning of the year. Please try to install the latest Aleos and Radio FW at the link and see if it helps to resolve the issue.
Please share more the log file if the issue still happens

Hello Vianney, thanks for your message.

I installed Aleos 4.14 ( was 4.09) and the current Radio FW for Verizon, but the problem still remains. While connected to the laptop and Ace Manager (***:9191) via Ethernet cable, it said “network link down”

Power Green

Network – flashing Red.

Attaching log file.

Thanks for any help.

Amartya Saha

filteredlogs.txt (1.11 MB)

Hi @asaha ,
Are you able to access ACE Manager webpage. If you made a factory reset on
ALEOS 4.14.0 or later have the ACEmanager local access forced to HTTPS only.
By default, ACEmanager should then be accessed using the default 9443 port: Please try and share your result

Hi @Vianney,

Yes I can connect to Ace Manager website via or :9443, but I get “Network Link Down” under Status.

BY the way, I did update to Aleos 4.14 as well as the latest radio firmware for Verizon downloaed from your website. However, when I check the ‘Software and Firmware’ button, I see an older version of the firmware installed in 2017 ( when we first started using this modem). I tried installing the firmware at least 3 times, but to no effect.

So what might be the reason for the modem suddenly not being able to access the network ? It worked seamlessly from 2017 until two weeks ago.

Another question – I have two other RV50s – one does not power up at all ( so trash it ? ) and the other has the same issue of not getting a network, but that modem;’ password was changed – is there a way to reset that password ?



So you have 3 problem now.
1- Cannot upgrade Aleos and Radio FW?
1.1 You should verify your device belongs in. Then select the Aleos + Radio FW corresponding to your device
My device is using module MC7430

Then I will use the FW for APAC

Please try and share the result
2- Cannot power on the device. Sorry I cannot support if that is hardware issue. You can contact the distributor. They might help to fix it
3. Change password without logging ACE Manage. If your device was registered to ALMS. You can change password from there.
Please share if you have any concern

1 Like