FXT009 resets on GPRS bearer start


#1

I have an FXT009 that I’m trying to use in TCP Server mode, over GPRS.
I have all the setup working (Open GPRS Bearer, APN, username, pwd etc…)

However, when I go to actually start the GPRS bearer (AT+WIPBR=4,6,0), the modem does a reset (light goes off, comes back on for a few seconds) and all the previous setup is lost.
However, it doens’t always do this. This morning, for example, I got an hour of so operation as a TCP server.

Cycling the power doesn’t seem to make a difference (even if I leave the power off for a few minutes).
What’s puzzling is that the modem sometimes works, but mostly just resets.

The modem has been returned to distributor who upgraded the FW to R7.44 from R7.43, and reported “Could not simulate the problem” (I think he meant “repeat”, but no matter…)

I should add that the SIM and account settings work fine in a Maxon Modmax 3G (MM-6280 chipset).

Any suggestions on what to do next?


#2

Did that make any difference?

Did you send him a complete, detailed log of exactly what you’re sending to the modem, and receiving from it?

Get back onto your distributor! Can you get him to visit to see this happening?


#3

Something to check, do you have a beefy PSU?
https://forum.sierrawireless.com/t/faq-forum-wiki/3491/1


#4

Obviously not.

Yes, I did. They made a suggestion about the APN (telstra.corp -> telstra.internet) which stopped the reset problem, but doesn’t actually allow me to make a TCP connection at all anymore.
It is possible this is a network problem, rather than a modem problem…

Unlikely. They’re in Sydney, 1000km away.

Yes, I thought of that. I tried a bench-top supply, but it didn’t help. It’s possible the modem is just faulty (in HW). The distributor is looking into swapping it for a new one.


#5

I guess thats because telstra.corp = CHAP APN. CHAP authenticaion over WIPSoft works only on R7.45. See 59502 listed in R7.45 release notes. Have you tried R7.45?


#6

I returned the unit to our supplier (again), and they replaced it.
The new unit seems to work fine, so I guess it was just a faulty unit.