GPRS issues with FXT009


#1

Good morning,

I’m new to Xtend, I was working a lot with Supreme. The problem I am facing now is: after AT+CPIN=, modem is logged in (light is flashing). Then, I’m trying to set the GPRS connection (dial-up) - it launches for few seconds then it gets disconnected and Xtend seems to be logged out (the light is continous). All of this happens even if I use an extern application to establish the connection.

Those steps above were perfectly enough to set the stable GPRS connection with Supreme.

My colleague tried Xtend under Linux with similar results. The only one utility that could actually create and hold the connection was Wvdial.

I am using WinXP Pro, SP3.
Firmware on Xtend: R7.46.0_fxt009.dwl
Xtend is connected to PC through RS.

Thank you for any suggestions.


#2

Same problem here. I tried the ftp_list sample given(adapted to connect to my ftp server) with M2M Studio and led remains blinking. Trace view returns the following:

2011/11/09;11:01:14:755;001;HLH;1;ARM Prefetch Abort caught at EA07A602, Current Task 0x1F by CP15
2011/11/09;11:01:14:755;002;RTK;1;================== RTK STATUS start ==================
2011/11/09;11:01:14:755;003;RTK;1;================== RTK STATUS end ==================
2011/11/09;11:01:18:599;004;SYS;1;Current OAT Task index : 0

This trace is repeated a few times until it stop tracing. Console output is as following:

AT+WOPEN=1
OK

+WIND: 13

+WIND: 1

+WIND: 16

+WIND: 7

+WIND: 4

+WIND: 10,“SM”,0,“FD”,0,“ON”,0,“SN”,0,“EN”,0

+WIND: 11,“EB2A6A5E70F5D5E911346E031922B528”,“C9E66FCAB4601B40E64B919FDC36A46D”,“84FF30275CD3A1D210DD27BCF19444F9”

My package is 2.36. Is the modem alright? May I talk to my distributor to change it?

Thank you.


#3

I don’t think it’s caused by a broken unit. I have checked several (3-4) Xtends and all of them behaved the same way. So, I guess the problem is that I do something wrong (some AT commands missed at initialization, wrong configuration of dial-up etc. Just guessing now).


#4

Mmmmm… In my case I forced factory settings and used a Sierra Wireless example from 2010 provided with my package, it can’t be anything wrong… :blush: