GPRS Connection through at commands


#1

Hi,
i want to connect to Internet via GPRS enabled SIM card on a Q2686 module. I was successful in setting de cgreg,cgatt,cgdcont, and cgqreq…
but, when i tried dialing to 99**1# it gave no carrier and got disconnected.
Also, i tried by configuring a new modem at baud rate 19200, then created a new dial-up connection and when i dialed to 99**1# got the error “Error 692: There was a hardware failure in the modem(or other connection device)”
I was able to connect to gprs via adl commands.
Can someone help me to configure the module? It’s urgent.


#2

This is too vague to give any suggestion - You need to show a complete log of exactly all the commands sent to the modem, and all the responses received from the modem.
Be sure to use copy-and-paste - do not try to manually re-type them!

Are you talking about Windows Dialup Networking here?

If you are using windows, look at the Modem properties in Device Manager;
On the ‘Diagnostics’ tab, there is the facility to create and view a log of all communications with the modem…


#3

Hi,
The following is the sequence of commands that i sent from hyperterminal:

+WIND: 16
at+cgreg=1
OK

+WIND: 4

+WIND: 10,“SM”,1,“FD”,0,“ON”,0,“EN”,0

+WIND: 11,“A90646215CFD526DAF0E44292EF32BEB”,“87DDDBDFF0179EC8C8A60C9597EE25E
E”,

+CGREG: 0
at+cgreg?
+CGREG: 1,0

OK
at+cgatt=1
OK

+CGREG: 2

+CGREG: 1
at+cgatt?
+CGATT: 1

OK

+WIND: 15,1,“Airtel”,2,“Airtel”,3,"+22",4,“09/03/25,08:50:33+22”,6,“0”
at+cgdcont=1,“IP”
OK
at+cgqreq=1,0,0,3,0,0
OK
at+cgact=1,1
OK
at+cgact?
+CGACT: 1,1

OK
atd99**1#
CONNECT 115200
~ }#À!}!}!} }<}!}$}%Ü}"}&} } } } }%}&} } } } }’}"}(}"}#}$À#‰U~~ }#À!}!}!} }<}!}$
}%Ü}"}&} } } } }%}&} } } } }’}"}(}"}#}$À#‰U~~ }#À!}!}!} }<}!}$}%Ü}"}&} } } } }%}
&} } } } }’}"}(}"}#}$À#‰U~~ }#À!}!}!} }<}!}$}%Ü}"}&} } } } }%}&} } } } }’}"}(}"}
#}$À#‰U~~ }#À!}!}!} }<}!}$}%Ü}"}&} } } } }%}&} } } } }’}"}(}"}#}$À#‰U~~ }#À!}!}!
} }<}!}$}%Ü}"}&} } } } }%}&} } } } }’}"}(}"}#}$À#‰U~~ }#À!}!}!} }<}!}$}%Ü}"}&} }
} } }%}&} } } } }’}"}(}"}#}$À#‰U~~ }#À!}!}!} }<}!}$}%Ü}"}&} } } } }%}&} } } } }
‘}"}(}"}#}$À#‰U~~ }#À!}!}!} }<}!}$}%Ü}"}&} } } } }%}&} } } } }’}"}(}"}#}$À#‰U~~
}#À!}!}!} }<}!}$}%Ü}"}&} } } } }%}&} } } } }’}"}(}"}#}$À#‰U~
NO CARRIER

And via windows modem configuration, i got the following log:
03-25-2009 14:23:14.828 - File: C:\WINNT\system32\unimdm.tsp, Version 5.0.2195 - Retail
03-25-2009 14:23:14.828 - File: C:\WINNT\system32\unimdmat.dll, Version 5.0.2195 - Retail
03-25-2009 14:23:14.828 - File: C:\WINNT\system32\uniplat.dll, Version 5.0.2195 - Retail
03-25-2009 14:23:14.828 - File: C:\WINNT\system32\drivers\modem.sys, Version 5.0.2195 - Retail
03-25-2009 14:23:14.828 - File: C:\WINNT\system32\modemui.dll, Version 5.0.2195 - Retail
03-25-2009 14:23:14.828 - Modem type: Standard 19200 bps Modem
03-25-2009 14:23:14.828 - Modem inf path: mdmgen.inf
03-25-2009 14:23:14.828 - Modem inf section: Gen192
03-25-2009 14:23:14.828 - 19200,8,N,1, ctsfl=0, rtsctl=1
03-25-2009 14:23:14.828 - Initializing modem.
03-25-2009 14:23:14.828 - DSR is low while initializing the modem. Verify modem is turned on.
03-25-2009 14:23:14.828 - CTS is low while initializing modem.
03-25-2009 14:23:14.844 - Send: AT
03-25-2009 14:23:14.860 - Recv: OK
03-25-2009 14:23:14.860 - Interpreted response: OK
03-25-2009 14:23:14.875 - Send: ATE0V1
03-25-2009 14:23:14.891 - Recv: OK
03-25-2009 14:23:14.891 - Interpreted response: OK
03-25-2009 14:23:14.891 - Send: AT
03-25-2009 14:23:14.906 - Recv: OK
03-25-2009 14:23:14.906 - Interpreted response: OK
03-25-2009 14:23:14.906 - Session Statistics:
03-25-2009 14:23:14.906 - Reads : 18 bytes
03-25-2009 14:23:14.906 - Writes: 13 bytes

But, when i use a dial-up connection, i get the error:
“Error 692: There was a hardware failure in the modem(or other connection device)”
What is the problem? Pls help


#4

Hiya,

A couple of things I noticed:

You’ve sucessfully connected to the GPRS network here. The ‘gibberish’ is PPP data coming from the other end of the link. As you didn’t reply in time with the correct data, the other end of the PPP link has shut down and the modem has hung up. All is happening as it should.

Are you using a full 9 pin cable to connect to your modem (and using UART 1 on the modem)? Windows relies on using ALL the hardware control lines to manage the modem state.
From your log, windows thinks the modem is [broken/not responding/powered off/not there] because the DSR line has not gone high as is expected on power up or reset. This is probably why windows is reporting a hardware failure.

Do you want to simply use the Wavecom device as a wireless dial-up modem (i.e. from Windows or Linux), or do you want to use the internal TCP stack to do all the hard work and simply send data back and forth over a GPRS connection using AT commands (i.e. microcontroller without TCP stack)?

If it’s the latter, you need to do the following:

  1. Check with your distributor that the modem is enabled for WIP
  2. Get the appropriate WIP AT application from your distributor and download it to your modem
  3. Read the WIP AT commands guide really well.

BTW, what modem are you using?

ciao, Dave


#5

Hi,
Thanks for the info.
I wanted to check on the GPRS connectivity on the hardware custom-built. Im using Q2686.
I was able to connect to GPRS through the firmware using wip. But, I would like to establish a wireless dial-up modem from my Windows machine.
Also, does someone know how the MMS works in fastrack modem? I would like to know how the MMS message received indication happens and how to parse the MMS data? i guess it is received as PDU data. But, i would like to know the entire sequence of MMS messaging, and also how to parse and compose MMS messages.
Expecting a reply soon.


#6

Hiya,

No problem.

I suspect that if you haven’t brought out ALL the flow control lines on your design, you’re going to have to make up a custom loop-back cable to trick Windows into thinking that you have a full 9 wire connection to your modem.

Can’t help you here. Sorry.

ciao, Dave