FOTA for FX30S how to

it does connect the modem but should also automatically connect to the airVantage?
I was doing it through the legato framework before and now I have stopped the application

+WDSI: 5 means authentication failure.

I can authenticate using the legato API, no problem with that.
The only problem I have is that all the systems operations will not work, I can somehow get it to change the communication status behaviour, but that is it.
Is there a separate section for the FOTA? And I may need to have a full subscription with Sierra Wireless to use these functionalities?
I also get a warning for firmware not recognized which I would need to clear once I know what variables I need to change.

To me, if AT command not working, I will not try with legato app.

I understand what you say, but I am fairly confident it does connect to the airVantage, as I get the handler to change status (and get the NO_UPDATE status which is coming from the server anyway) and also the last seen on the airVantage is updating.
Also got it to change the communication settings from the AirVantage server.

The modem is reacting to the sms, and it will start the avc session when triggered, this works as well.

I don`t entirely understand if I am doing something wrong with the le_avc interface or with the setup or triggering of the airVantage server, I am closing the session straight after getting the status NO_UPDATE, and open it periodically (every 10m) to check if there are new updates available.

How do you explain +WDSI: 5 is returned?

I don’t explain it, as for most of the stuff we have done this is more a process of trial and error instead of properly understanding the process. Anyhow, the module is surely connecting to the airvantage or it would not update the heartbeat. I get very alternated pinging results, changing from 400 to 1700ms, could that be a cause? Also if the module was not authenticating properly I can’t see how the handler could return the SESSION_STARTED and NO_UPDATE unless this is a bug with the interface and app.

you can try other module and see if +WDSI:5 is still returned.
If no, go back to your application and see what happens.

I have remove my application which was using the modem data and also the le_avc interface, rebooted the unit and tried with AT commands:

Manufacturer: Sierra Wireless, Incorporated
Model: FX30S(WP7702)
Revision: SWI9X06Y_02.16.06.00 7605a6 jenkins 2018/06/20 17:56:12
IMEI: 354723090144204
FSN: VU007185430210


+CGDCONT: 1,“IPV4V6”,“telstra.wap”,“”,0,0,0,0

+CSQ: 16,99

+CREG: 0,1

+CGREG: 0,4

+COPS: 0,0,“Telstra #StaySafe Telstra”,7

+CGACT: 1,1

Current Time: 423 Temperature: 27
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 2 Mode: ONLINE
System mode: LTE PS state: Attached
LTE band: B28 LTE bw: 20 MHz
LTE Rx chan: 9410 LTE Tx chan: 4294967295
EMM state: Registered Normal Service
RRC state: RRC Idle
IMS reg state: No Srv

PCC RxM RSSI: -79 RSRP (dBm): -106
PCC RxD RSSI: -79 RSRP (dBm): -140
Tx Power: 0 TAC: 9019 (36889)
RSRQ (dB): -10 Cell ID: 0901BF0B (151109387)
SINR (dB): -1.8


+WDSI: 4

+WDSI: 5

+WDSI: 7

+WDSI: 8

This is for both of my units, if I check the “cm data” status straight after forcing the connection to the airVantage, then I see the data connection is available and I can also ping the backend:

root@fx30s:~# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=216 time=594.068 ms
64 bytes from seq=1 ttl=216 time=411.583 ms
64 bytes from seq=2 ttl=216 time=1164.217 ms
64 bytes from seq=3 ttl=216 time=883.030 ms
64 bytes from seq=4 ttl=216 time=460.506 ms
64 bytes from seq=5 ttl=216 time=411.693 ms
64 bytes from seq=6 ttl=216 time=516.115 ms
64 bytes from seq=7 ttl=216 time=698.745 ms
64 bytes from seq=8 ttl=216 time=602.533 ms

Still it will not authenticate, so my questions are:
-What is the reason??
-What is the meaning of +WDSI: 7 and also 8?

Is this because I have registered the units wrongly or for what other reason?
Connection is available so the unit is able to communicate with the backend.


Why previously it is ok on your side?

I thought the AT+WDSS=1,1 was forcing a connection to the airVantage, which command should I use instead?
I have shutdown the application, removed them, rebooted the unit and then run the AT+WDSS=1,1 command.

Why previously it is ok on your side?

you mean previously when I was testing this from with the legato API?
Have no idea honestly, this is basically the reason why I have opened this post.
The only thing I have modified in this unit is the ssh login password for root as we want to prevent unwanted login to the device by third party, not that I believe this will make any difference but worth to mention as we are guessing on what the problem could be.

you said before that AT command is working fine:

If I trigger the AT+WDSS=1,1 then the it seems the modem will try to establish the connection (setup the data connectivity) but it will not work.
If I start the data connection manually (cm data connect) and after trigger the AT command, then the test is successful.

nah, that was related with the legato API, which I have solved.
The AT commands as far as I can remember have never worked properly.
If I go back to use the legato API for the avcService I still get the connection through but don`t receive any update (LE_AVC_NO_UPDATE) regardless of the system command I use.

I don’t see problem with AT command on my WP76.
Maybe you can try some more module and see what happens.

I have two modules with the same problem, so your solution would be to buy some more and to try if the problem persist with all of them?

you can give a try as other user does not have same problem as yours:

you might also see this:

You might also see the firewall:

Finally you might also try on legato 19.11 :

root@fx30:~# legato version
root@fx30:~# microcom /dev/ttyAT

one of the forum doesnt have any solution, not sure how I can use that. Tried to change the firewall settings and not good result. With the WDSI commands, I cant set it to 8191:

This is what I read from the target.

+WDSI: 4479

+WDSC: 0,0
+WDSC: 1,0
+WDSC: 2,0
+WDSC: 3,0
+WDSC: 4,15,60,240,480,1440,2880,0,0
+WDSC: 5,0
+WDSC: 6,0

beside this, once again, the latest firmware for the FX30-catm is R11 based on legato18 and this cannot be updated to any firmware we wish. Cant connect to the sierrawireless webpage (which should be down at the moment) so cant confirm if there was a new release, it should still be working with the older firmware thought

→ one of the forum doesn t have any solution, not sure how I can use that.
I just want to show you that other user does not have +WDSI:5.

BTW, you can use leaf to download wp77 fw