Fota hl7800

Hi guys,

I’ve been trying to update the firmware via FOTA, but unsuccessfully.

I entered the information as required by the portal

The device is there but it seems to never synchronize, the arrows are always grey.

I tryed issuying , but nothing happened:

AT+WDSI= 3,15
OK

AT+WDSS = 1,1
OK

And follows my readings from the AVMS commands

What things should I be aware of to make sure I am doing the right thing?

thanks in advance

Hi @joao.bino,
Please follow commands then try again
AT+WDSI=4479 // enable +WDSI: indication
OK
AT+WDSS=0,”” //config APN for AVMS connection
OK
To trigger the connection from module
AT+WDSS=1,1 //Start the connection to server
OK

+WDSI: 4

+WDSI: 6

+WDSI: 23,0
+WDSI: 4 // displays the current state of authentication notification
+WDSI: 6 // displays that the session has succeeded and has started
+WDSI: 23,1 // displays that the target has successfully connected to the AirVantage Service
Thanks

@Vianney Thanks for your reply

I tried but the result is this

AT+WDSS=1,1
OK
+WDSI: 7
+WDSI: 8

AT+WDSS=0,””

This command gives an error. I also check the AT commands manual and it is a deprecated instruction

What else could I try to check?

Thanks,

Hi @joao.bino

You can ignore this command if you already configured APN in cgdcont command. Let check
at+cgdcont?
Normally, When you send wdss=1,1 the module will receive
+WDSI: 23,0
+WDSI: 4 // displays the current state of authentication notification
+WDSI: 6 // displays that the session has succeeded and has started
+WDSI: 23,1 // displays that the target has successfully connected to the AirVantage Service
Now it is showing +WDSI: 7 and +WDSI: 8. Please double check below
Step 1. On AVMS, verify that your module is added firmware like screenshot


Add the FW here
image

Step 2. On the module, it shows WDSG=0,2 and 0,1 it means your module has not authenticated with AVMS server.
Please help check
at+cereg?
at+cops?
at+cgdcont?
at+wdsi?
at+wdsc?
at+wdsg?

Thanks