ES450 missing MDN value after carrier swap

We have experienced a strange issue where the Phone Number value now shows as NA in AceManager after swapping carriers from Verizon to T-Mobile. This device is part of a KORE managed VPN pool. The device is properly assigned its own ip address from the pool and we can pass traffic over it, but we need that phone number to be listed in order for some custom applications of ours to work properly. Is that something that I can overrride by way of AT command? Is there another way to get there? I know that the MDN info is on there on the SIM, if we put this SIM in a Cradlepoint unit then it recognizes the phone number. This has happened to about 4 or 5 devices that we converted last week. Is it possible that when I added the T-Mobile radio module firmware matters? I also updated firmware to while doing the conversions and there are two paths to take to upgrade the radio module firmware, I’m wondering if one of the paths was responsible for this issue. Your help is greatly appreciated on this.

Hi @appdev ,
I tried to reproduce the issue by swapping between Generic and Sierra carriers on RV50X using Aleos 4.9. I don’t see the problem. Sorry I cannot test on ES450 because it is not available here
Please provide the below info to understand the situation

  • Reboot the GW helps to resolve the problem?
  • Does the GW successfully register to T-Mobile network after swapping from Verizon to T-Mobile?
    I swaped carriers from Generic to Telstra

The GW still get phone number after this swap

Please feel free to share any questions you have.

No, a reboot of the Gateway made no difference. Is there an AT command that could be used to update the phone number field? I know on legacy documentation that you could provision the 3210/3211 Airlink devices by using AT*PROVISION=000000,XXXXXXXXXX where the 0’s were the lock code and the X’s were the mobile device number. What are my other options at this time? Going back out into the field to mess with the physical hardware isn’t a viable option in the near term.

Hi @appdev,
I cannot find anything like the AT command on GW’s guides so I am not sure you can provision the phone number device to Airlink GW. Did the issue happen when you use Generic FW? Let consider using it if the Phone number is displayed on Generic

For this testing purpose, you can consider the ICCID number to identify the device. It is displayed as the screenshot

Please share if you have any concern