Error "+WDWL" Setting up the WMP100 using dongle

Using the DWLwin and the dongle key I downloaded the R71a01-cus-wmp-01.wpk file into the flash of the WMP100. When the download process is finished, the DWLwin confirmed that everything was ok. Then I restart the WMP100 and the first thing that it sends is the +WDWL string.

if i send the “AT” command the WMP100 responds “OK”. If I send the “AT+WDWL?” command the WMP100 responds “+WDWL: V08b03”. To any other command the WMP100 responds “ERROR”.

What am I doing wrong?

Hi aldanajaramillo,

Try this:

  • Relaunch the download via DWLWIN
  • In DWLWIN, before starting the download, please don’t tick the box “customize files”, this should solve your trouble.


I had the exact same problem with WMP100 using DWLWin V, except I was downloading R71-cus-wmp-02.wpk.
Having wasted several hours scratching my head and cursing Wavecom I came across the answer on this bulleting board and now works fine. I’m not sure if the problem lies in the WMP100 or in DWLWIN, but please Wavecom - you need to fix this !



I think I have a similar problem:
If i send the “AT” command the WMP100 responds “OK”. If I send the “AT+WDWL?” command the WMP100 responds “+WDWL: V08b0k”. To any other command the WMP100 responds “ERROR”.
I get V08B0K instead of V08B03.
I’ve tried solution proposed by ToF but it doesn’t work for me!

Can anybody help me?

Thank’s in advance.

Nobody knows about this error?


You mean you’ve been using DWLWin with a Dongle?

If you have a Dongle, then you must be in touch with a Distributor or FAE - have you asked them?

Have you had an AT+WDWL download failure? If so, the unit will respond with ERROR to everything until you restart it with AT+CFUN=1

Thanks awneil,
I have asked to my distributor and said to me to download firmaware again. I’ve tried it several times and it doesn’t work! because of this I ask to you to know if someone have had a similar error.
I don’t know whats happening because it worked fine before.

I think I’m missing something during download process.

Thanks in advance.

Then get your distributor on the phone, and have them talk you through the process step-by-step.

Better, get them to come to you (or you go to them) to work through the problem together.

Is it just one device, or can you not program any devices at all?

Other devices that are in a board developed by us can be programmed without any problem but Dev Kit doesn’t seem to work.
Also, I’ve tried putting other wmp100 chip provided with Dev Kit an download firmaware to it and have the same behaviour.
It’s strange behaviour becuse process ends with succesfull state.
I’m going to ask to my distributor to change Dev. Kit.

Thanks, I’ll post any news regarding this issue.

Sierra Wireless have sent me a new Dev. Kit.
No problems with new one.