EM9191 module locked up or crashed

Have a new EM9191 module, along with a USB Modem enclosure/adapter.

Upon first attempting to connect to the network, LTE, 5G, the module wasn’t connecting, and I didn’t keep any logs, so I don’t have much data re: initial status. With the exception of the firmware update, all of my work is on a Linux desktop, Arch rolling release 6.1.7-arch1-1 x86_64 GNU/Linux

Firmware update
I Updated the firmware on a Windows 10 machine, first updating to SWIX55C_01.07.19 The installed fw was SWIX55C_01.07, but lower revision than 19 and updating straight to SWIX55C_03.09.14 failed. I read that the SWIX55C_01.07 needed to be updated first. Then the update to SWIX55C_03.09.14 succeeded

Back to Linux 6.1.7 desktop
At this time, I needed
modprobe option
echo 1199 90d3 >/sys/bus/usb-serial/drivers/option1/new_id
in order to have the AT command port.

I downloaded and compiled the R30 Drivers, SDK, etc. I entered make install and mkinitcpio -p linux (Arch Linux), and rebooted. Still no AT command port. At this time, it’s clearly a matter of drivers, etc, all software config.

The device was appearing with lsusb but not all drivers.

Searching for a solution (exercise in futility) I read a comment about fixing this ala usb_modeswitch and tried one or two incantations. I don’t know what changed, but
now the device no longer appears in lsusb

As a user without a development kit I have limited hardware reset options,
which the summation of my question.

Can I perform a hardware reset without access to the development kit?
Or rather, how can I perform a hardware reset without access to the
development kit?

On photos of the development board, there are two reset buttons
PCIE RESET SW300
MODULE RESET SW301

My enclosure/adapter has 9 jumpers, and the documentation lists the following
1: Ground
2: PIN 68 - ANT ?
3: 1.8V
4: MODELE0
5: MODELE0
6: 1.8V
7: Ground
8: PIN 25 - Test ?
9: 1.8V

In the EM919x/EM7690 Product Technical Spec pdf
The M2 Host interface pins shows the following pin assignments

PIN 25 DPR Dynamic power control
PIN 50 PCIE_PERST_N PCIe Reset
PIN 67 RESET Reset Module
PIN 68 VCC Power Source

So, with no direct, one to one, pin to pin, I’m not going to experiment

On page 38, Table 3-8, Full_Card_Power_Off# and RESET# Use
RESET, PIN 67, says the following

This is a ‘hard’ reset, which should be used only if the host cannot communicate
with the module via the PCIe or USB port. (If the port is not working, the module
may have locked up or crashed.)

Which describes the state of my module.

And
To reset the module, pulse the RESET# pin with a logic low signal for 400–800 ms

Could I use a simple logic pulsar to send the pulse direct to PIN 67
to reset the module?

Hi @sierrawireless8,

Please refer to the following ideas:

  1. As far as I understand you were able to connect EM9191 successfully on win10 computer right?
    So what does your Device Manager page show, please give me a screenshot.
  2. Can you tell me the specific steps you installed MBPL driver?
    Could you please give me more information about your Linux host? (By using some commands: hostnamectl, uname -a,…)
  3. Are you using Sierra dev kit or customer board. If it is possible, please help recheck on Sierra dev kit whether the problem is resolved

Thanks,

hostnamectl
Static hostname: sabretooth
Icon name: computer-desktop
Chassis: desktop :desktop_computer:
Machine ID: a32fbd462eb6457abd9eead3b73dae4e
Boot ID: d0beef48a552433aad03bd4700eba6e3
Operating System: Arch Linux
Kernel: Linux 6.1.8-arch1-1
Architecture: x86-64
Hardware Vendor: ASUSTeK Computer INC.
Hardware Model: SABERTOOTH 990FX
Firmware Version: 0705

Yes, I WAS able to see it, both windows and linux, but NOW I AM NOT.

I have two boards that I can use to test with, but they are both USB interface. One is simply an adapter, the other is an adapter/enclosure.

I clearly documented all details in the original post, but to summarize.

The device does NOT appear in dmesg, nor in lsusb.

It needs to be RESET, and I DO NOT have a development board.

My Salesman says he is trying to contact his rep, but that has been going on for weeks now. Presumably his rep was on vacation for New Year and may be back today.

Can I reset without access to a development board?