EM9191 Get Linux Connection (solved)

I have an EM9191 connected via USB 3.0 to my Ubuntu machine with the proper USB drivers built and installed. I can get serial connection to issue AT commands however the device “wwan0” is stuck in down state. When I attempt to bring it up with “ip” command it doesn’t get an IP, so I dhcp onto it and it never gets an address. I’m not sure the steps to gain full connectivity on Linux as in Windows it get a connection from drivers and works as expected. I have Modem Manager and Network Manager installed. I tried to enable the device through modem manager but no changes. Not sure the steps I need to take to get it working properly?

did you install the MBPL USB driver?

You can use MBIM command to start the data establishment:

Yes I did. It seems I now have it working through mbim-cli with the proper config and script. But band locking seems to not be working and the module currently is locked onto LTE, switching to 5G NR only bands disconnects me from network. Should I open new thread with this issue?

yes, you can open a new thread with more detail about your issue