EM7430 not waking up after firmware update on windows 11

I have my EM7430 on a M.2 NGFF to USB3 adapter. At first this device works properly, the blue LED on the USB adapter turned ON, and I can get 4G signal from it. But I could not find the COM port to perform AT commands.

Then I tried to update the firmware using the official firmware tool from https://source.sierrawireless.com/resources/airprime/minicard/74xx/em_mc74xx-approved-fw-packages/#sthash.VoDf7kLy.dpbs this link.

The update failed because maybe it cannot find the COM port. But now the Modem does not work anymore. Windows cellular indicator showing that the device is plugged in, but no service available. Windows Device manager also still showing the network adapter DW5816e snapdragon X7 LTE. There is still no available COM port.

Any help would be appreciated.

Screenshot of the fw update window provided.

what do you see on device manager?
Any serial port?
Any modem port?
Any network interface?

If it only has one DM port in device manager, probably you need to run the fdt tool manually.
Here is an example for EM7511 with DM port onlye:

fdt2.exe -f SWI9X50C_01.14.03.00.cwe SWI9X50C_01.14.03.00_GENERIC_002.036_010.nvu

Hi here is a screen capture on the device manager. No COM port that indicates the Modem, but the GPS seems like to be working, I tried to open the Maps app and it can show detail location of the device.

where can I download the fdt tool from?


where can I get those Images?

SWI9X50C_01.14.03.00.cwe SWI9X50C_01.14.03.00_GENERIC_002.036_010.nvu


I don’t see any port that is related to the module…

EM7430 FW:

Does that mean this card is bricked?
Is there anything else I can do?

you can try in virtual machine with linux

Also see if this help to reinstall the usb driver:

The generic driver setup link is not showing anything to be downloaded.

I tried it on Ubuntu and the device can be seen on the USB device list

Can you please show me on how to install the driver in linux (the driver files are in kernel objects), and which one to choose?

you can download the “MBPL_DRIVERS_R30_ENG1-usb-src.tar”


I just realised how difficult it is dealing with device driver and Linux. I will give up going for linux.

Can you recommend another model of 4G Modem card with M.2 interface with GPS/GNSS that I may be able to use worry free?


There is an update, I tried to install it on a Windows 10 VM, and in the device manager, there is this indication mentioned below.
could it mean that the device somehow went to a some kind of DFU state and cannot go to a normal state?

not sure if this is hardware issue if you don’t have more clue like linux environment or another PC