EM7305 - Problems with firmware update


#1

Hi everybody,

we are trying to update the firmware of an EM7305 modem and running into lots of problems. Have tried various methods but none seems to work.

On Windows 7 the driver can not be installed and subsequently the FW updater can not find the modem at all.

On Windows 10 the driver can be installed, the updater finds the modem, but will hang later, waiting for a download port.

Also I have tried several of the linux updaters, on an x86_64 system (kernel 4.14.48) and on an arm system (Raspberry, tried with kernels 4.9.50 and 4.14.49), without any success. Without going into much detail, the result was sometimes an error message “No modem connected” or “modem not in correct state”, but in most cases the firmware downloader just hangs when it’s about to start the download.

Is there a combination of operating system and firmware updater version that is known to work?

Under Linux, which driver (modules) need to be present, which ones should be blocked?
Does the modem have to be in a particular configuration or state before starting the fw update process?

best regards,
Rolf


#2

Rolf,

I’ll try to answer as simply as I can.

  • No the unit does not need to be in a specific state other than its normal operational one when starting a download.
  • I currently use my Ubuntu 14.04/kernel 3.14 laptop with the latest SDK and drivers from the source.
  • Simple gotchas are that the currently logged in user does not have read/write access to the /dev/qcqmi interface or that the slqssdk file does not have its +x attribute set.
  • Re the drivers to make sure that you are using the Sierra drivers you need to delete (or rename) the qcserial.ko and qmi_wwan.ko files, then in stall the Sierra ones.

I have attached an example of me updating an MC73, the SDK is quite old because I did it a long time ago (but then so is the MC73).
MC73 upgrade success.txt (8.4 KB)

Hopefully that will help.

Regards

Matt


#3

Thank you for your reply, Matt!
Until now I was using the drivers from the standard linux kernel. As it turned out, I indeed needed a driver from the Sierra web site, SierraLinuxQMIdriversS2.26N2.38.tar.bz2 (there’s also an older version that did not work for me).
In the source files for GobiSerial and GobiNet I needed to add the USB IDs 9062 and 9063 for the EM7305. Also I had to downgrade my Kernel to version 3.16, as the driver could not be compiled with 4.x., but then finally I was able to install the drivers and successfully run the firmware downloader.

Thanks again
Rolf