DeveloperStudio not loading packages from repository


#1

Hello,

I´m beginning in the world of Sierra Wireless and I´ve got a GL6100 where I expect to do a serial communication gateway tp GPRS so that I can receive my data on a REST API on my web site.

So far, so good, I´ve downloaded and installed Developer Studio 3.6, plugged my GL6100 in the serial port, put a SIM card and powered it up.

I can connect to GL using HyperTerminal, but it´s not connected to the GPRS network - no led blinks, not signals at all: AT+CSQ returns 99,99, AT+CREG? returns 2,2… not even on manual. I suppose this is a lack of firmware on the unit…

Browsing around I found out that I need the 7.47 OpenAT Firmware for the unit. I then went to Developer Studio->Help->Install new software and selected the following site:

Open AT Embedded Software Suite repository - updatesite.sierrawireless.com/packages/OpenAT

“Threre are no categorized items” is what I got. Then I tried:

updatesite.sierrawireless.com/packages

Same error.

I´m now stuck at this point and don´t know how to make my modem work. I need help to move further. Why is the sierra link not working ? Why is the modem not connecting ? Does it come without a firmware from factory ?

My goal is to continue the DevStudio to build my own application and to test the AirVantage platform.

Thanks for helping.


#2

Open AT packages are installed from the Package Manager perspective, not from the traditional Eclipse interface to install Plugins.


#3

Unable to load packages from
updatesite.sierrawireless.com/airvantage

in package manager perspective.

Also want to install MQTT connector libraries.