Developer Studio 1.2.0 available


#1

Dear DS users,

Please note that Developer Studio 1.2.0 is now officially available for download and update.

There are some important notes to read before any upgrade of a former version, so please have a look to the release note: http://www.sierrawireless.com/Support/AirPrime/releasenotes/Developer_Studio_1_2_0.aspx

This new DS release brings a totally revamped Target Management perspective, fixing many reliability & stability bugs of former versions of DS and M2M Studio. The other key new features are:

  • Target Management support under Linux
  • Multiple targets connectivity
  • “Developement Mode” persistence over a target reset
  • Backtraces decoding

Another significant improvement has been done on the download server side: installer download links now point to a new hosting solution, providing reliable download support wherever you are located.

Enjoy using this new Developer Studio release!


#2

Great, thanks, too bad I have other projects on other devices to attend to and can’t switch to it, but in time I’ll be happy to try it :wink:


#3

I did a clean install of eclipse 3.6 (on Ubuntu), pointed to the url [updatesite.sierrawireless.com/developerStudio] and get hash errors. Any hint would be appreciated.

[The extension txt is not allowed.]

An error occurred while collecting items to be installed
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,org.eclipse.cdt.debug.core,7.0.0.201009241320.
MD5 hash is not as expected. Expected: 0052c6d0fd7ca9d1edbbd65d18c3dd8c and found 7643b1b5f52fcb5cdae31e4dd5e01099.
Problems downloading artifact: osgi.bundle,org.eclipse.cdt.debug.mi.core,7.0.1.201009241320.
MD5 hash is not as expected. Expected: eda5a6d1163d89763225c113c8b09c15 and found 6aa2f689670d8fa31f55da6f9ef63252.

[ snap… many more ]


#4

Please try to download separately one of the indicated bundles (e.g. updatesite.sierrawireless.com/de … 241320.jar) and get its md5sum, to confirm the issue.
From there (in France), the bundles are correct, but maybe they shouldn’t be correctly refreshed in the server cache corresponding to your location.
Is it your first installation try, or have you made test earlier (and when)?


#5

yesterday I installed 1.2.0 from wavecom.com/eclipseUpdates/m2mstudio. Since the target management throws a java NULL pointer and I saw in this release note that it should work, I tried to update. But eclipse said the version was already installed, so I got a clean eclipse package and tried the new url. Don’t know if that has anything to with it. I will try again and check the hashes.


#6

ok installation worked now. I started with an none existing workspace. The original " problem" remains though, java NULL pointer exception in all target management views.

java.lang.NullPointerException
at com.swi.tm.ui.commons.views.PortWorkbenchPart.hashCode(PortWorkbenchPart.java:35)
at java.util.HashMap.get(HashMap.java:317)
at org.eclipse.ui.part.PageBookView.getPageRec(PageBookView.java:693)
at org.eclipse.ui.part.PageBookView.partActivated(PageBookView.java:749)
at com.swi.tm.ui.commons.views.AbstractTMPageBookView.switchPort(AbstractTMPageBookView.java:160)
at com.swi.tm.ui.commons.views.AbstractTMPageBookView.createPartControl(AbstractTMPageBookView.java:112)
at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:375)
at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:229)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
at org.eclipse.ui.internal.Perspective.showView(Perspective.java:2245)
at org.eclipse.ui.internal.WorkbenchPage.busyShowView(WorkbenchPage.java:1071)
at org.eclipse.ui.internal.WorkbenchPage$20.run(WorkbenchPage.java:3822)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage.java:3819)
at com.swi.tm.ui.commons.ViewUtils.createViewWithSecondaryId(ViewUtils.java:44)
at com.swi.tm.ui.commons.views.AbstractTMPageBookView$2.run(AbstractTMPageBookView.java:141)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3515)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3164)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)


#7

In “Packages Manager” view already installed packages under “Default Sierra Wireless Repository” now looks like boxes without text until selection (white on white text?).

Windows XP SP3. Auto-update from 1.1.2.


#8

They should indeed appear in light grey… Maybe something to do with your system colors configuration? Looks fine here…


#9

Do you have “real” serial ports on your system?
USB ports are unfortunately not supported under Linux with this version.


#10

Windows XP style, standard Olive color scheme, no any style gadgets.

And another one: all available packages doubled…


#11

During updating error occurs, something about MD5 error. This place from error log i suppose:

After restarting update complete successfully.


#12

no I don’t this is USB /dev/ttyUSB0 serial converter.


#13

Shoot me… I installed the “Source Code” from the update site to have a quick look at why the device was not found. This required restarting Eclipse and now I a target management on /dev/ttyUSB0. Not sure what caused it, but it is working now…


#14

Good to know…
The bug (cf NullPointerException stack trace you’ve posted) occurs if DS doesn’t detect any port on the system…
If your USB-Serial converter wasn’t plugged the first time you opened the Target Management perspective, it could explain…


#15
  1. On another machine the same installation (update from 1.1.2) complete without MD5 or any other errors. Good.

  2. Invisible packages only on Olive color scheme, Blue and Silver looks OK.

  3. After studio restart and with empty “Available repository” list after pressing button “Refresh selected repositories” all found packages always doubled. If “refresh” one more time with collapsed “Default Sierra Wireless Repository” packages appears singled (OK). If “refresh” with expanded root item, one or two more refreshes needed.


#16

My upgrade went smoothly. But now my existing projects fail in the final link stage.

It’s because of multiply-defined symbols “adl_InitIRQLowLevelStackSize” and “adl_InitIRQHighLevelStackSize”. I have them defined in my app, but they are apparently also defined in a default lib:

myApp.c:88: multiple definition of `adl_InitIRQHighLevelStackSize’
C:\Program Files\Sierra Wireless\Embedded Software\com.wavecom.openat.ide.spm.lib.os.model.6.32.0.03_6.32.0.03\resources\ADL\gcc_wmadl_6.32.03.0.0.lib(adl_stkdefault_hlh.o):(.rodata+0x0): first defined here

Any ideas what changed in Studio 1.2.0 to effect this?


#17

Did you?


#18

Yes. I tried to re-create the workspace and import the projects into it. But I got the same error. Log file is attached.

Thanks.
AppBuild.zip (1.11 KB)


#19

Hi guys

I have also installed the new version, everything seems fine except that the WIP plugin WILL NOT install. It was missing when I first installed so i tried to install in in the package manager but I got the “Unable to install” error (with the very helpful reasons provided - not!), so i deleted all the packages from the Embedded software folder, and tried to reinstall just the packages, but once again, WIP would not install. Very frustrating. Anyone have any ideas?

Thanks!
Tom


#20

Hi Tom
I have installed WIP plugin (5.40 & 5.30 for tests) with the new version from the Package Manager.
Do you still have the problem ?