Developer Studio v2.2.1

Dear all,

Developer Studio 2.2.1 has just been released.

It is a maintenance release of Developer Studio 2.2.0, no major features has been added.
Please check latest release notes.

Existing developers has been notified to update their Developer Studio to last version.
Or, download Developer Studio with Open AT Application Framework now.

Thank you
Christophe

Hello,

I am using DS 2.1.0 version and I want to upgrade to DS 2.2.1 (win 7 pro)

Check for update show the availables update with 2 lines

  • Open AT projects management 2.2.1.201206182207-R9541
  • Target Management 2.2.1.06182209-R9667

terminate with error (The operation cannot be completed with the following details)

I tried the light installer V1-3-2 selecting only Developer Studio and PC drivers but the program say’s that DS is already installed and I have to use Cehck for Update !

How is it possible to complete the process

I had the same problem. What I did is to manually delete the DS folder (C:\Program Files (x86)\Sierra Wireless\Developer Studio) and then use the Open_AT_Framework_Light_Installer_v1-3-2 to reinstall DS2.2.1.

That’s true that software installer has been designed to only handle first time installs, not for upgrades.
Concerning the upgrade from 2.1.0 to 2.2.1, we’ve made the test on a fresh 2.1.0 install, without any issue.
Maybe you’ve installed some other plug-in on top of 2.1.0, adding a dependency which cannot be resolved with 2.2.1

Anyhow, if you cannot fix your DS install to make it able to upgrade, you indeed still have the option of installing a new DS instance in another directory (or in the same when, but you’ll indeed have to wipe it out manually before).

Update went smooth here too, last “full” version I have installed was 2.0.0 I think, running updates ever since.

thank’s to all,
I have installed DS2.2.1 after renaming previous DS --> installation OK

It was not possible to build old project, error with “adl_global.h” not found as it is the same include in all my src.
Renaming 1 #include to <adl_global.h> solve the problem.

After, the Selection of Clean Project doesn’t succeed, the following error is reported

This command was good in DS2.1.0

Going back to previous DS, it is still working ;

Creating a new instance of project in DS2.2.1, Clean Project not working, I have to build by using Build all.

I discover also that not all errors are reported. Project is not build, and not error reported in Red in the Bottom Problems panel

There is a behavior change in CDT version integrated since (AFAIR) DS 2.1.1: the “Clean Project” command doesn’t trigger a build anymore after. It means that if you want to clean + rebuild after, you’ll have to trigger it manually.
On another hand, it’s true that the clean command always reports errors in the console, but normally this doesn’t prevent CDT to clear the build directory correctly.
We expect this issue to be fixed when we migrate to a makefile based system.
Concerning the project settings issue, please refer to this post for information on how you can expect to fix your project settings: https://forum.sierrawireless.com/t/developer-studio-project-settings-problem/5694/1

Why :question:

I’ve Just started using v2.2.1 - and I’m getting this same error:

Surely, ‘del’ is an internal command - so it shouldn’t be looking in the PATH?! :confused:

There is no “del.exe” executable. “del” is a built-in command of the Windows shell, and can’t launched as a Windows process (and that’s what the internal CDT builder try to do here, so it fails…)

Anyhow, we’re close to release the next DS release, with beta alternative implementation of the build system based on makefile generation. And we paid attention to handle correctly the “make clean” command.

Exactly!

So why does it do that?? :open_mouth:

It didn’t used to have this problem - so what changed?

Do I take it that this is an Eclipse problem, and not specifically DS…?

:smiley:

Yes, you’ll have the issue even when building a win32 app with CDT.
The problem has always been there.
The sole difference is that before, when asking for clean, a full build was immediately triggered just after.
Since the latest integrated CDT version, it doesn’t trigger the full build anymore, so you can see that clean build error message in the console.

The solution around this is to add a del.exe somewhere on the path. If you look around the sierra tools there is a file in one of the bin directories named something like sw_rm.exe. A duplicate of that named del.exe it worked fine for my purposes. (Which is shrinking my build directories down before I do a hard backup)

Well, strictly, that’s just a workaround - not a solution! :wink:

More of a hack just to get things working.

Doesn’t build great confidence in Eclipse to see such howlers :exclamation: :open_mouth:

Again, Eclipse CDT community seems to massively prefer makefile-based build system, and that’s the way we’re going to follow in DS too…