install studio 2.2.1 on indigo linux 64bit fails


#1

it seems that a package dependency of Open AT projects management is conflicting with the one installed on indigo, all other studio plugins can be installed:

Your original request has been modified.
“Target Manager” is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Open AT projects management 2.2.1.201206182207-R9541 (com.wavecom.openat.ide.devenv.feature.group 2.2.1.201206182207-R9541)
Software currently installed: ShellEd 2.0.0.201111150942 (net.sourceforge.shelled.feature.group 2.0.0.201111150942)
Only one of the following can be installed at once:
Dynamic Languages Toolkit Launching Core 3.0.0.v20110423 (org.eclipse.dltk.launching 3.0.0.v20110423)
Dynamic Languages Toolkit Launching Core 2.0.0.v20100201-1709 (org.eclipse.dltk.launching 2.0.0.v20100201-1709)
Cannot satisfy dependency:
From: LuaEclipse_feature 1.0.0.201003311322 (com.anwrt.luaeclipse.feature.group 1.0.0.201003311322)
To: org.eclipse.dltk.launching [2.0.0,3.0.0)
Cannot satisfy dependency:
From: Open AT projects management 2.2.1.201206182207-R9541 (com.wavecom.openat.ide.devenv.feature.group 2.2.1.201206182207-R9541)
To: com.wavecom.openat.ide.lua.feature.group 0.0.0
Cannot satisfy dependency:
From: Open AT Lua Support Extension 2.2.0.201204271318-R8788 (com.wavecom.openat.ide.lua.feature.group 2.2.0.201204271318-R8788)
To: com.anwrt.luaeclipse.feature.group 0.0.0
Cannot satisfy dependency:
From: Open AT Lua Support Extension 2.2.1.201206181634-R9540 (com.wavecom.openat.ide.lua.feature.group 2.2.1.201206181634-R9540)
To: com.anwrt.luaeclipse.feature.group 0.0.0
Cannot satisfy dependency:
From: ShellEd 2.0.0.201111150942 (net.sourceforge.shelled.feature.group 2.0.0.201111150942)
To: net.sourceforge.shelled.ui [2.0.0.201111150942]
Cannot satisfy dependency:
From: ShellEd UI Plug-in 2.0.0.201111150942 (net.sourceforge.shelled.ui 2.0.0.201111150942)
To: bundle org.eclipse.dltk.launching [3.0.0,4.0.0)

on helios works.

bye,
Luca


#2

DS is indeed requiring a specific DLTK version, which seems to be not compatible with the DLTK version provided on Eclipse Indigo.
We’ll have a look to fix that in the next release.