Dev Studio in Ubuntu (32bit)

Hi guys,

REALLY new to Ubuntu, but tried to get Dev Studio installed in here. Everythign seems fine, but I cannot for the life of me

  1. Open Target Management Perspective
  2. Create an actual application!!! (I cannot hit “Next” once I get to the first screen of starting a new project)

I got the attached two errors. Any suggestions for this newb???


Hi guys,

Just an update. I tried to install on a Mac running current Lion. Same results. Any help out there? Please?


for the target management, make sure you have libunixsocket-java installed.


Good morning all,

Jeroen - Thank you for the feedback on this post. I have installed libunixsocket-java as per your sugegstion, however this did not change anything. :frowning:

So I figured I would do an “Idiot’s guide” type follow-up as I am confident there are numerous others that would like to use a non-Windows platform PC, while retaining tools availability. Ultimately, I would like to get this working on OSX as I am contemplating buying a Mac.

So here we go. I will attempt to describe what I did and hoperfully the screenshot attachments will remain in the correct order.

  1. I followed the very short installation description on Sierra Wireless’ website for linux based installation.
  2. I downloaded the EclipseIDE (Indigo) 3.7 SR1.
  3. Extracted and moved to /home/apps

to be continued…


  1. Ran the file “eclipse” and as expected, was required to specify the workspace. I just kept the default, ticked “Use as default…” and “OK”.

  2. From here continue as per SWI instructions, and went to Help->Install New Software… and added the update site’s URL. Then selected the options that I require (as per recommendation in SWI instructions) and hit “Next”.

to be continued…

  1. Followed through with the confirmations as requested by the installation process, and then the update / installation commenced…

to be continued…

  1. Did receive a security warning which I accepted, and once the installation was done, I selected to restart eclipse when asked.

  2. Once newly opened, I attempted to switch to the three “OpenAT” perspectives. First was the actual “OpenAT Perspective”…

to be continued…


  1. Smiling as it looks like it should. Next, “Packages Manager”…

Hooray.!.!.!.!.! (I think…)
I can confirm that the “Packages Manager” works as it should and I was able to download and install all the available “OpenAT Framework Packages”/OASiS.

to be continued…

  1. Now for the last one… “Target Management Perspective”

now after a short delay, things went dark. Literally…

and finally I get the error as mentioned originally.

So my mission is to get this resolved and then go further to actually create the world famous “Hello World” and then download and run it on a target.

ANY help would be greatly appreciated!!!


DS 2.2.X versions add support for USB under Linux, but also require additional packages to be installed on the system (even if you don’t plan to use USB…)
Please give a try with

sudo apt-get install hal libdbus-java

Should work better.

LEGEND!!! Target Management Perspective now open and I seem to be able to create a Hello World! Now to figure out how the OS can see the device! :slight_smile:




OK. No idea how to get the port to show up. The only way I get it up and visible is through running eclipse as a super user. (So I assume I don’t have persmission to use the USB connection or something) Connecting to the device is also a problem.


I can confirm that I can send AT commands in the console.



regarding the permissions, add yourself to the dialout group.

Jeroen - The permissions did the trick. (I suspected this was the case the other day when trawling the web, however wasn’t 100% sure) It did not work initially, however after loggin out and back in it then worked.

The errors received when openning the port however still remain, so I guess this would be something that the team from SWI would need to shed some light on?


Hi all,

So I got the same error when connecting that device to my Windows based Dev Studio. Loaded FW 7.45 onto it and both Windows and Unubtu based Dev Studios opens the port to the device without trouble.

PS. FW 7.47 was on the device when I was seeing the errors


Considering the port opening issue, it sounds like your device is locked in development mode on another port.
Even if you get an error, do you get answers to AT commands in the console view?
If yes, give a try with AT+WDM=0 command, and reset the device. After that, information should load correctly by refreshing the status view.

Good mornign Daav,

I can confirm when I tried later again with 7.47 on both Windows and Ubuntu plaforms, it opened fine and without problems. So your comment on this beign firmware related would make sense. (although not systematic)


Good evening guys,

I have a follow up on this, but just based on OS X. We have an issue with installing an OASiS package. It starts, but soon after starting it pops up with this error below.

Also, when trying to switch to the “Target Management Perspective” the below error pops up. (Same as I got on Ubuntu) The problem is that the suggestion made by Daav before, (udo apt-get install hal libdbus-java) results in an error. Also see below.


Any suggestions? :slight_smile:


Hi guys,

An update on the OS X side of things.

I posted the below in topic [url]]

"Hi guys,

Just an update. Currently standing in the Apple store, and the patch gerard67 mentioned above seems to work. I now have Target Management Perspective loaded in OS X. I didn’t bring my FXT with me to test connectivity though. LOL!

[attachment=0]Screen Shot 2012-07-14 at 12.04.08 PM.png[/attachment]


I am guessing the inability to install the packages is something simple like permissions or something.

This is the last step before actually getting a device connected and compiling and running a Hello World. Please, the gurus out there, share your knowledge!!!