Getting Developer Studio Working on Mac OSX (Mountain Lion)


#1

Good morning guys,

OK, so I have decided to move to a MacBook Air running Mountain Lion. Everything I need to do works well however I knew that I would need to revive a topic I started prior to my purchase of the Air. (See https://forum.sierrawireless.com/t/dev-studio-in-ubuntu-32bit/5697/1)

I decided to start off using the instructions currently provided by the release notes (for version 2.3.0 here developer.sierrawireless.com/en/ … 2_3_0.aspx) and all ran fairly smoothly. The first step is to get packages installed and although Packages Manager opens up, updates and shows me all the options I need / expect to see, a couple of seconds after starting the install, I get the window below (note this has been reported by others too running on Windows platforms)


So firstly I need to resolve this, and then the next step is to get Target Management to actually open up. At this stage it simply doesn’t do anything! :frowning:

I figure with so many people moving to Macs, this “How-To” guide would be really handy to have.

So all the clever guys out there, please provide some guidance if you have the knowledge.

Cheers,
Tyrone


#2

Hi,

Can you try to uninstall and install the developer studio again.And see if the proble still persists.In that case,share the error logs.

Thanks.


#3

Hi rex_alex,

OK, so I “reinstalled” everything starting with Eclipse Juno SR1 (link from the release notes of 2.3.0) with installation components as below:




Once all done, I ran eclipse again and openned Packages Manager, refreshed the repository and tried to install framework package 2.51 with the same result as before.


I am afraid there are no error logs that pop up. The screenshot above is all I get.

How can I help further?

Cheers,
Tyrone


#4

The package installation system is implemented by triggering another eclipse instance, to deal with the plugins installation (since Sierra Wireless Software Packages are Eclipse plugins). The trigger process is platform specific, and there are probably unhandled specificities on Mac OSX.

As a workaround, you can install the Software Packages through the classic Eclipse interface (Help > Install New Software), by using the same URL that is presented in the Package Manager perspective (updatesite.sierrawireless.com/packages - URL for Eclipse usage only, nothing displayed in a web browser).
The only differences with Package Manager interface is that packages will be installed in your Eclipse “plugins” directory, and you’ll need to restart Eclipse to get them displayed in the installed packages, but from there it should work as usual.


#5

Good morning Daav,

Thank you very much for the feedback! I have managed to progress a little. I have followed your recommendations and after fiddling a little, I managed to see all the OpenAT components. :smiley: Below is a screenshot. (Note that items are not categorised, so will not display. You have to un-tick this box to see them)


Looking good. Waiting for installation to finish…

Tyrone


#6

:frowning: Drat, no luck.

So all the components installed fine and Eclipse restarted once done. In Packages Manager I can see all the packages installed, so this was quite positive.


So with this done, I tought I would try to generate a “Hello World”. Well this did not go very far, but at least there were some error messages that should mean something!


What to try next? :question:

Cheers,
Tyrone


#7

OK, so I decided to revisit my previous attempt before I got the Macbook Air. Using Eclipse Indigo installation, and also doing the RXTX “mod” shown in the thread (forum.sierrawireless.com/viewtop … 108&t=6264), I get to about 66% of the way to create a new project. I have checked that the toolchains are installed, but still faced with the error screen below. Suggestions?


PS. Using the mod with the Indigo installation also allows me to open up Target Management Perspective! Whoo hooo! 8) (No port are showing though… :frowning: )

Cheers,
Tyrone


#8

We are only providing toolchains for Windows and Linux.
You should try to get one running on Mac OSX.
Unfortunately, the one we integrated (provided by former Code Sourcery, now Mentor Graphics) has not been built for Mac OSX, but you can grab the source, so maybe do the build yourself?.. :neutral_face:

Please go there: mentor.com/embedded-software … e-edition/
And select ARM processors --> Download the EABI release
It will bring you to a free registration form, to get the download link by email.
Once you get the link, select the 2009q3-68 release (this is the one which is integrated in DS, for Linux & Windows)
Then you should be able to get the toolchain code & build configuration… You just need to build it for Mac OSX now…
Good luck!..

Another hassle you’ll get is that some Sierra Wireless command line tools are also required to fulfill the build.
And these tools are also only provided for Windows & Linux.
We are not familiar at all with Mac OSX, but maybe something similar to wine (to execute Windows binaries on Linux) is available?
To be continued…