Using Developer Studio on Linux


#1

HI All,

I’m having issues installing & using Developer Studio on my linux box (Ubuntu 10.10 x86_64).

I’ve installed as per these instructions (using eclipse 3.6.1 as mentioned in this post) and installed the add-ons’ (both ‘Developer Studio (all in one)’ and the whole ‘Toolchain Binaries’ option).

I now assume that I would need to install/copy a SDK of sorts (I’m developing for the AirPrime Q2687)?
(e.g. there are no SDK or OS etc. options in the new Project Dialog, and there is definitely no adl_global.h to be found :slight_smile: ).
I’ve had no luck finding any further details and there is nothing in the devices downloads section that I can see.

The only other time that I’ve set this up was on a Windows box using the all-inclusive installer and I don’t remember having to install a separate package for the sdk.

Any information would be most appreciated :slight_smile:


#2

You indeed need to install a SDK to be able to create Open AT projects.
Please go to the Package Manager perspective, select the Sierra Wireless repository in the “Available Packages” view, and press “Refresh” to get the list of the available SDKs.
From there, just choose your version and install it…

Actually on Windows this is entirely managed by the installer, but it’s true that under Linux, you have to handle this “manually”


#3

Excellent, thank you for that daav.

That seems to have solved that problem, unfortunately I seem to have come across another couple :stuck_out_tongue:.

If I create a project, close Eclipse/Developer Studio then open it again I get this error message (Test1 being the project name that I just created):

Problem Occured
'Setting up indexer(‘Test1’) has encountered a problem.

An internal error occurred during: “Setting up indexer (‘Test1’)”.

Details
An internal error occurred during: “Setting up indexer (‘Test1’)”.
java.lang.NullPointerException

And the editor shows an error message too.

I’ve also created a ‘clean’ .log file to attach. That is, I cleaned out the log then started dev studio again to just capture these errors, but it appears that i’m unable to add attachments (tried with the extensions .txt, .log and nothing).

While writing this I checked a couple of things and notice this post that points me to this eclipse bug report but as mentioned in the previous post I am using the suggested 3.6.1 version.

The 2nd issue that I’m experiencing is that I can’t download the built application, it just sits there apparently not doing anything for ages (I left it for ~15 minutes just in case). Although that may be a linux permissions thing (for the serial ports).


#4

Mmmm, sounds like using Eclipse 3.6.1 is not enough… Let’s follow this issue in the topic you’re linking to…

Is your target correctly responding to AT commands in the Developer Studio console?


#5

Just and update, sorry for the delay but I’ve had to be concentrating on something else for the past wee-while.

I followed the suggestion in the post mentioned in my previous post (regarding ensuring the ‘Contact all update sites during install to find required software’ is un-ticked) and that seems to have sorted the issue of the ‘Setting up the Indexer’ error :slight_smile:.

But since then I’ve had sporadic success with serial communications (and subsequent downloading of the application onto the module). But more often than not i’m experiencing the error: ‘No Serial Port is associated with the launch’.
The first time that I received this error I was able to click the ‘Run’ (green circle with white play button) button’s drop-down options and select run-as->Open AT Target Application which gave me a port selection dialog box. This isn’t happening now. I’ve sometimes had to manually rm the lock file (/var/lock/LCK…ttyUSBx) as well which apparently helps if I’m lucky.

I’ve also used the Target Management screen to connect to the port, but that doesn’t appear to help either.

Is there something that i’m not doing with regards to setting up the serial port with the project? Or is there some other flakiness involved?


#6

Alright, with a little more fiddling it seems I’ve come up with a semi reliable method of getting it to work.

If I close the project and open it again it appears to bring up the port selection dialog whenever I click the Run->Run As->Open AT Target Application.

I’m wondering if there was an issue first time round because these projects were originally made and worked on from a windows box. So having pulled them from the repo and set them up this first time round, they should be all sorted from now on (we won’t be using the windows platform from now on, so it removes the need for it to be cross-platform in that sense).

So at this point to looks like I’ve got a workable Linux platform for development. Thanks for all the help and suggestions guys :slight_smile:


#7

I have just installed the Helios 3.6.1 “Eclipse IDE for C/C++ Developers” under Ubuntu 10.04 LTS. In accordance with the instructions in one of the Linux related postings I have added the Developer studio Plugin.

Now when adding the packages under suite 2.33.0. … from the available packages I have managed to install the Firmware package (7,43), the Open AT OS package (6.32), and the GR Open At Plug-in Package (2.8). [I’m not sure what the latter is - it installed as part of a “select all packages” install which failed as below].

Anyway the issue now is that it won’t install the WIP Open AT Plug-in package (5.30). I get the “Impossible to install selected package” message in an “Install Error” dialog window.


What do I need to do change in order to successfully install the WIP plug-in?

Eric


#8

Can you have a look at the ./dropins directory of your Eclipse installation?
Check if there is a directory for WIP plug-in partially installed, and remove it before trying again the installation.
And anyway, please attach the error log to this thread (.log file(s) located in the .metadata directory of your workspace)


#9

Just made a test on Eclipse 3.6.2 + DS 2.1.0 over Ubuntu (11.10 64 bits), and the whole 2.33 SDK was installed…


#10

For some reason this BBS isn’t letting me add the log file as an attachment. I get the message:

“The extension log is not allowed.”

I have tried changing the attachment filename to “Eric.txt” and just :Eric" - nothing works - always the same message.

So, what am I doing wrong - why can’t I add the log file as an attachment on the BBS?


#11

There is no directory shown for a WIP plug-in within the ./dropins directory.

By the way, when I first tried the original developer studio installation it was under Eclipse 6.3.2 and was unsuccessful so I reverted to installing it under 6.3.1. Developer Studio then installed OK so its just a case of getting the WIP plug-in installed now.

I will try moving the various subdirectories out of the .dropins directory and see what happens.


#12

Just zip the log and it should be OK.
We already observed some package installation issues under Linux, but it seems to be quite random, and that’s why we have to analyze the log to see if it’s something new or not…


#13

Attached as requested.
Eric.log.7z (12.3 KB)


#14

Seems that you have troubles to access to some files on the repository.
Can you try to access to this URL from your browser?
updatesite.sierrawireless.com/pa … 0.2040.jar

If you can’t get it with the browser, there is probably an issue with our cache server in your area.
If you can get it, there should be an issue with the cached data of the repository in Eclipse.
In both case, please advise…


#15

Yes, this link worked OK with the Browser and so the .jar file has now been downloaded, thank you.


#16

Ok, so that sounds like a known bug we have when Eclipse puts some information in cache while it’s not necessary…
To try to fix it, you should try going to the Preferences > Install/Update > Available Software Sites, and removing updatesite.sierrawireless.com entry.
Anyway, once you have the jar file, you can also unpack it a subdir of the dropins directory and restart your Eclipse: the package will be installed.


#17

Have removed the update site form the list.

Now trying to get the latest package as a test. Seems like the server is quite slow?

It would be helpful if there was some kind of progress indicator as it downloads each file as “retrieving data” isn’t particularly informative.



#18

Yes, that worked thank you.


#19

Yes, we know that… We’ve logged in the roadmap to improve the package installation system, especially to give more visibility on install progress…


#20

I’ve been trialling Developer Studio 2.1.1 in a Windows XP virtual machine under Linux. It has many improved features so I’d like to run it directly under Ubuntu 10.04.

Has anyone managed to get Developer Studio version 2.1.1 running under Ubuntu 10.04? What is involved compared to the previous installations and what version of Eclipse is required?