Data Throughput with wp7608 cat-4


#1

Hi ,

we are able to achieve the below throughput numbers with the 10 MH z bandwidth of band 3 signal

Downlink: 35.3 Mbps
Uplink: 20.3 Mbps

Below is the lte info
at!lteinfo?
!LTEINFO:
Serving: EARFCN MCC MNC TAC CID Bd D U SNR PCI RSRQ RSRP RSSI RXLV
1575 001 01 12594 00000E06 3 3 3 30 52 -5.9 -74.0 -51.1 –

IntraFreq: PCI RSRQ RSRP RSSI RXLV
52 -5.9 -74.0 -51.1 –
InterFreq: EARFCN ThresholdLow ThresholdHi Priority PCI RSRQ RSRP RSSI RXLV
GSM: ThreshL ThreshH Prio NCC ARFCN 1900 valid BSIC RSSI RXLV
WCDMA: UARFCN ThreshL ThreshH Prio PSC RSCP ECN0 RXLV
CDMA 1x: Chan BC Offset Phase Str
CDMA HRPD: Chan BC Offset Phase Str
OK

We are able to achieve 70 Mbps downlink with the same Network & other UE(Bittium Phone).

From the specs, its mentioned 150 Mbps(DL) & 50 Mbps(UL) for 20 MHz Bandwidth. Please correct me If I am wrong.
changing any settings on the modem will improve the downlink ?
Please let us know your inputs.

Thanks,
Siva


#2

@stirulaka,

So do you have both antennas connected or a single one? Generically speaking the unit will go as fast as the network will allow it to, there are no settings on the unit that will change this, you are also going to need to be a little more specific/detailed about your test method.

Regards

Matt


#3

Hi Matt,

We had 2 antennas connected.
We are able to get the DL around 65 Mbps for the 20MHz Bandwidth.
But the same test setup with the other UE gives around 120+ Mbps.
we are using the below iperf commands in both the cases
iperf –s –u –i 2 –p 4321
iperf –c 172.22.1.201 –u –b 60m –t 1000 –p 5002 –l 1470

Any suggestions why we are not able to get the same numbers ?
Let me know if you are looking for more information . so that I can share with you.

Thanks,
Siva


#4

Siva,

The only way to sensibly test throughput is to use it against atest set like a CMW so that you have end to end control. I do not know what is limiting the unit here but there is clearly something reducing the performance of the unit.

Regards

Matt


#5

Hi Siva,

we are using the below iperf commands in both the cases
iperf –s –u –i 2 –p 4321
iperf –c 172.22.1.201 –u –b 60m –t 1000 –p 5002 –l 1470

From where do you send these commands?

  • From WP7608 embedded Linux console?
  • From PC? (which OS?)

Could you try this command:
iperf –c 172.22.1.201 –u –b 145M –t 1000 –p 5002 –l 1472

Jay