MC7455 + WE826 - Slow Speeds (VZW)


#1

So I setup a MC7455 in a WE826 router. It’s up and running but I’m having issues with speeds. On my Note8 I get 40-60 Mbps down easily. On my router setup, I’m connected and only getting between 5-15 Mbps down (upload is always higher, 10-20). I verified I’m connected to same tower and on the same band (B4).

Any ideas/advice is much appreciated.

Thanks!


#2

Hi mathena2,

Throughput is affected by many factors, network/signal/band, USB interface/driver, host, etc.

Can you share more info:

  • Which driver and how data connection is established on WE826?
  • Any chance WE826 is using PPPD?
  • Does same issue happen when you test MC7455 connect to PC (over USB)?
  • Please check and share “AT!GSTATUS?” return?

And you may get some info from similar post below using same WE826:

Thx


#3

Not sure on driver… does this help? - ROOter ZBT-WE826 GoldenOrb_ Build 2017-12-15, LEDE 17.01.4 r3560-79f57e422d

What is PPPD?

Do not have a a USB enclosure for it. It’s hooked up inside router

Current Time: 6774 Temperature: 47
Reset Counter: 1 Mode: ONLINE
System mode: LTE PS state: Attached
LTE band: B4 LTE bw: 20 MHz
LTE Rx chan: 2150 LTE Tx chan: 20150
LTE CA state: NOT ASSIGNED
EMM state: Registered Normal Service
RRC state: RRC Connected
IMS reg state: No Srv

PCC RxM RSSI: -69 RSRP (dBm): -97
PCC RxD RSSI: -70 RSRP (dBm): -102
Tx Power: 0 TAC: 7400 (29696)
RSRQ (dB): -15.1 Cell ID: 01C53D16 (29703446)
SINR (dB): 4.6


#4

Sorry, I don’t have info about WE826.

But seems like signal is not good, maybe you can check (or try different) antenna?

Thx