Connect Mihini Agent to Airvantage M2M Cloud


#1

Hi,

Following the Developers guide https://doc.airvantage.net/display/USERGUIDE/Connect+your+device I have been able to setup a Mihini Agent on a beaglebone black that sends data to the m2m.eclipse.org M3da server. However, my issue is that I have not found any information in order to connect my device to the AirVantage M2M Cloud.

I’ve followed the guide in order to add the device to my inventory, and activate it. Currently it’s communication status is pending, which I believe is caused because my device is not pointing to the correct server.

Does anyone have information, or know where the information is so that I can continue my evaluation.

Thanks you in advance for your time.

Bob


#2

Hi bquenneville !

I am glad to read you have successfully connected to the open source server !
And now let’s see how we can help you go the next stage, and hopefully grow a sustainable solution with AirVantage!

Can you share with us what is the URL you are using to connect to the AirVantage M2M Cloud portal, and also what is the device communication URL you are using in your application ?

Cheers,
Gillo


#3

Hi Gillo,

Here’s the server settings from my defaultconfig.lua file.

server = {}
    server.serverId = "AIRVANTAGE"
    server.retrytimes = 10
    server.retryperiod = 60

    -- Determines the protocol, host, port, and optionally other things such
    -- as path, user, password
    server.url = "tcp://m2m.eclipse.org:44900"
    --server.url = "http://localhost:8070/device/com"
    --server.url = "http://webplt-qa.anyware-tech.com/device/com"
    --server.url = "http://webplt-m2m.anyware-tech.com/device/com"
    --server.url = "http://m2mop.net/device/com"

    --When the device is behind a proxy this settings defines a HTTP proxy. This parameter is only relevant for HTTP transport protocol
    --server.proxy must be a URL starting by "http://".
    --server.proxy = "http://some.proxy.server:port"

    -- Security: authentication is one of "hmac-sha1" or "hmac-md5" (or nil)
    -- Encryption cannot be enabled without authentication. It's of the form
    -- "<cipher>-<chaining>-<length>", where cipher must be "aes", chaining is
    -- either "ctr" or "cbc", length is either "128" or "256".
    -- server.authentication = 'hmac-sha1'
    -- server.encryption = 'aes-cbc-128'

    -- Agent auto connection policy
    server.autoconnect = { }

All the best,

Bob


#4

Hi Gillo,

I solved my connection issue. I found the response on bugzilla for the Mihini project https://bugs.eclipse.org/bugs/show_bug.cgi?id=413495. The correct server.url in order to connect to the Airvantage M2M Cloud in my case was tcp://na.airvantage.net:44900. It would be good that the instructions on how to connect to the correct server be found within the Airvantage Developer Guide https://doc.airvantage.net/display/USERGUIDE/Connect+your+device.

I hope this will help other people searching for answers.

All the best,

Bob


#5

Many thanks for the feedback Bob, and that was indeed what I had in mind.
Great job in finding the correct answer in the bug tracker and I did forward to the appropriate team your suggestion of improvement on the documentation.

Cheers,
Gillo


#6

Hello Bob,

I add the information in the page Connect your device. It should be published in a few week.

Thank you for your feedback !

Regards,
Robert